Issue: Registering Stake Pool/Submitting Transaction

I running into a problem when trying to register a stake pool with meta-data. When I try to sign and submit the transaction… I keep getting this error:

Error while submitting tx: ApplyTxError [LedgerFailure (DelegsFailure (DelplFailure (DelegFailure (StakeDelegationImpossibleDELEG (KeyHashObj (KeyHash “xxxx”))))))

I’ve gone deleted files and retried these steps multiple times but keep getting the same error. What am I doing wrong?

Hi Tyler,

Have you executed a transaction to register your stake address?

What guide are you following?

Thanks in advance

Your friend, FROG

Would be helpful if you post the actual comman you use to register the pool. From the error message one could think you did not register your stake address correctly?

Hi Frog,

I am following the Pool of Africa guide (

I believe I registerd my stake address. That is registered using this command:

cardano-cli shelley stake-pool registration-certificate
–cold-verification-key-file cold.vkey
–vrf-verification-key-file vrf.vkey
–pool-pledge YourPledgeInLovelaces
–pool-cost YourFixedCostInLovelaces
–pool-margin YourPoolMarginInPercentage
–pool-reward-account-verification-key-file stake.vkey
–pool-owner-stake-verification-key-file stake.vkey
–mainnet --pool-relay-ipv4 TheIPaddressOfYourRelayNode
–pool-relay-port 3000
–metadata-url TheURLYouShortened
–metadata-hash TheHashOfYourPoolMetadataFile --out-file pool-registration.cert


Is there a way to withdraw the funds I sent to my payment.addr address back to my daedalus wallet so I can start from scratch.

Hi Tyler,

The command you provided creates the registration certificate for your stake pool, and not for registering your stake address.

And yes, you can manually craft a transaction to send your Ada from your cli address back to a Daedalus address. I recommend following this guide for details on creating transactions:

Let me know if you get stuck or need help.

Your friend, FROG

So If I want to send all the ADA (550 or 550 mill lovelace)

cardano-cli shelley transaction build-raw
–tx-in MyTXHash#NumberofTransactions
–tx-out Daedalus Address + 550000000
–ttl TTL
–fee 182925
–out-file tx.raw

Would the transaction look something like that?

How funny to fall upon this from one day ago and I am getting the exact same error while trying to stake from the cli.
I followed exactly this to register my keys:

and then this to stake:

It seemed to work for one address, but for another address I keep getting the same error as the original poster. Maybe because I have 2 UTXO for the same address? I have chosen the older UTXO to register and to stake.