Registering stake pool error: Error while submitting tx: ApplyTxError [LedgerFailure (DelegsFailure (DelplFailure (DelegFailure (StakeKeyInRewardsDELEG (KeyHashObj (KeyHash

I need help at the step where I send the fee to register the stake pool. At least i think that’s where I’m stuck.

I get the error after these commands:

cardano-cli shelley transaction submit
–tx-file tx.signed
–mainnet

The error is:

Error while submitting tx: ApplyTxError [LedgerFailure (DelegsFailure (DelplFailure (DelegFailure (StakeKeyInRewardsDELEG (KeyHashObj (KeyHash “REMOVED”))))))]

NOTE: I removed a value and replaced it with “REMOVED” (In case it’s a private value).

I’ve gone back through instructions and re-done parts, but still get the same error. I think MAYBE I already sent the transaction somehow. Because I got to around this step about a month ago, but didn’t complete everything. But I’m guessing and I dont recall exactly.

Also the address I’m sending from has this balance (lovelace):
598817955

So I dont think it’s a balance problem.

This error means the stake address was not registered properly prior to registering the pool. The registration may have failed, or the stake cert was generated using the wrong keys.

Double check your stake address - make sure it can be derived from your stake.skey and stake.vkey, and also double check your stake.cert creation - make sure it is created using the right stake key / address files. Then register your stake address, then register your pool

Your friend, FROG

Thanks, it appears in my case I had already sent the transaction. This was causing some kind of rejection. I’ve registered the stake pool and everything is working fine.

Here’s a big juicy snack for your assistance:

image

1 Like