KES keys expired - trouble rotating

My reminder for the rotation of the KES keys cocked up and as it was due to be my first rotation, I completely forgot.
I tried to rotate using CNTOOLS but I seem to have failed.

Any advice on how to check status, and what to retry would be much appreciated.

Screenshot 2021-09-14 at 20.31.11

journalctl -e -f -u cnode

Sep 14 19:59:19
/opt/cardano/cnode/scripts/ line 57: 43180 Killed cardano-node “${CPU_RUNTIME[@]}” run --topology “${TOPOLOGY}” --config “${CONFIG}” --database-path “${DB_DIR}” --socket-path “${CARDANO_NODE_SOCKET_PATH}” --shelley-kes-key “${POOL_DIR}/${POOL_HOTKEY_SK_FILENAME}” --shelley-vrf-key “${POOL_DIR}/${POOL_VRF_SK_FILENAME}” --shelley-operational-certificate “${POOL_DIR}/${POOL_OPCERT_FILENAME}” --port ${CNODE_PORT} “${host_addr[@]}”

Sep 14 20:47:26 Listening on

type cd ~/tmp

./ -f

It will download again the files… after that u will need to go and edit again:

  • the topology file (a bkp file was created)
  • the env file (cnode port + pool name line - a bkp was created)
    Then restart the node and check in glive

PS: what is the hardware configuration of the server?

Thank you, I will try it now.

4 cores

Aa ok, stop, I think 8G is not enough for 1.29.0 version (will be in future but not right now)

I did check after the update and it was running @ 5.9GB

Yeah, but few hours latter the node crashed… because it requires more RAm… if u want to test it… go to config file and set the TraceMempool to false… save the file and restart the node

Now it should use ~4G RAM but u will not see tx processed anymore

ok so:
step 1 upgrade to 16GB RAM
step 2 fix KES keys

First test with tracemempool set to false and check if the BP will start, if yes then yeah upgrade it to 16G or perhaps u can enable 2-3G swap

Not starting. It looks like I have no node.cert file

Wait…. It will take few minutes… type top

Do u see the cpu ~100%?

yes looks like it’s jumping fro 80 to 120%

1 Like

Wait more time…

ok I will leave it for a bit and try gliveview in the morning. thank you for your support

1 Like

Should the top of gliveview say “relay” for my producer? I thought it should say “core”?

It will say “relay” until it starts, then it will change to Core.

ahhh ok thank you.

hmm I think that’s enough time to try to connect.
if anyone has suggestions I’d be much obliged.

Screenshot 2021-09-15 at 08.09.35

type journalctl -e -f -u cnode

what is the output? try to share the output since you restarted the node… there are any issues?
and one more thing… how is the relay? can u share the glive output for the relay?