Ledger Seed is different from Daedalus/Yoroi/Adalite seed

The private key for a Ledger-created Daedalus/Adalite wallet is hidden in the Ledger-device and the Ledger seed is not identical to the seed that I would need to restore this Daedalus/Adalite wallet without a Ledger-device.

You can’t restore a Daedalus-Ledger-created wallet without having a Ledger-device.

Since money is all about trust, this fact makes you dependent on a working Ledger-device and the Ledger-seed. No way to restore a wallet ONLY from seed words. It’s human nature to have a non-technical backup access.

1 Like

Hey @HPHeuer, welcome!

Your backup access is the Ledger seed phrase itself. You should be able to restore all your wallets using that, with any Ledger device or BIP-39/44 supported wallet.

image

This is not accurate.
You can restore your ledger wallet into a bip39/bip44 software wallet.

I’m not familiar with the technical details, but can you give me a practical example, which wallet-software I can use, to restore my Daedalus-Ledger-wallet without the Ledger-Device, just with the Ledger seed? Then should show my ADA wallet.

I tried it on Daedalus, but couldn’t restore my wallet only from the Ledger seed without the Ledger-device.

Which bip39/bip44 software wallet would be able to do this?

Thanks!

But you can still use google, right?
Here’s the first result I got to get you started -

You shouldn’t rely on other people to do the work for you. that sounds snarky, but it’s actually meant as honest advice. Good luck!

I googled a lot before asking, but so far none of the wallets in your and my list support native Cardano and uses a 24 word seed (as the one from my ledger), to try them on the Cardano blockchain. Except Daedalus/Yoroi/AdaLite, and it’s not working there as described.

Somebody wrote in a different forum that Ledger is using a different BIP-algorithm to create the private key from the seed.

He wrote (translated) : “normal” wallets use the Derivation Path 1852’/1851’/0’/0, but Ledger uses 1852’/1851’/0’. Therefore the key-pairs are calculated different with the same seed.

I would consider this a huge bug/problem with the Ledger device, if this is true. They should fix it in some way.

3 Likes

Hi

Hopefully this thread can help you with your question

Cheers

Thanks, but I’ve already read that thread. They have not found any solution on how to restore a Ledger-created ADA-wallet from the Ledger-seed, BUT without the Ledger device.

No it doesn’t seem like it at the moment. I’m pretty sure though you can enter your 24 seed phrase into another compatible hardware wallet like a Trezor and still access your Ada if Ledger went out of business. Maybe someone more knowledgeable in this field could help or advise

Nice to hear mate, hope you are successful.

You can’t restore a ledger created wallet with Cardano at the moment using just the 24 word recovery phrase. This is because Cardano has a custom way of deriving the root private key from a recovery phrase but Ledger instead uses the standard that other cryptocurrencies follow

1 Like

Thanks for the information. I’ve just posted a Deadalus feature request to IOHK Support " Restore from Ledger-created-wallet without Ledger-device" with all the details.

My request would be a 3rd option in the Daedalus “Restore A Wallet”-dialog with the title “Restore from a Ledger wallet”.

It’s just a Peace-of-Mind thing, but trust is so important.

3 Likes

Good. Alternatively you can buy yourself another hardware wallet and use it as a backup unit

I have already 2 Ledgers set up with the same seed. Maybe I add a Trezor.

Quite some money, but really peace of mind.

Just to be sure if you didnt know: Only Trezor model T is currently supporting cardano

1 Like

…and most likely not compatible to the Ledger seed, to restore the same Daedalus wallet. And according to the Trezor-docs Cardano is only supported through third party wallets. The same as Ledger.

Sounds like a lot of work to bring all this together in a simple, standardized way. But its urgently needed for the End-User to feel confident with the new financial system.

2 Likes

FYI: As an experiment, I managed to restore the keys and addresses for a Ledger Nano X, but without that hardware, using the procedure below. Needless to say, one should never enter the seed phrase of a hardware wallet into an untrusted environment as described here if one has used or intends to use the wallet with that seed phrase for transactions. However, you can test this procedure out with a discardable seed phrase generated randomly by the Ledger. In a real-life key-recovery situation, it would be far safer to just purchase replacement hardware.

  1. Use the aforementioned script at <https://repl.it/repls/EvenFairInformation#index.js> to compute the root private key. (FYI: I plan to rewrite the script in Haskell, and will post a link here someday.)
  2. Use a Bech32 conversion tool to convert the hexadecimal representation of the root private key into a Bech32 one with the root_xsk prefix.
  3. Use the cardano-wallet, cardano-address, and/or cardano-cli tool to generate as many payment and change keys and addresses as you need to recover funds from. Here or here are example instructions.
  4. If you’re recovering funds, manually create and submit transactions using cardano-cli to move the funds from the recovered addresses.

Also, I don’t believe that the “Export Your Accounts” procedure on the Ledger website would recover keys for Cardano, because Cardano addresses derive the root private key from the seed differently than Ledger.

2 Likes

This is great. Could you please forward your solution to the Daedalus developers that they may add an option to the “Restore A Wallet”-dialog with the title “Restore from a Ledger seed”? This must be added to next Daedalus release and or to AdaLite/Yoroi.

I’m just an end user and not a developer, and when I tried to access your replit link, I was asked to register. I’m sorry, but I’m also not familiar with the Daedalus CLI interface.

I think Ledger is screwed with this seed incompatiblity. I can’t imagine a way on how they can fix this in their Cardano app. But I’m in touch with the Ledger support and mentioned this issue also to AdaLite.

As described in one of your links, Trezor is doing it right, so I will order a Trezor-T and check it out.

1 Like

FYI: Here is the link to Haskell code that computes the Ledger Nano X root private key from the seed.