No incoming peer and 0 pending tx after change ip

Hello, good morning guys

I have configured with CNTOOLS a stake pool in the PreProd testnet, everything was going well until 2 days ago when I had to move and so restart my router(changing the IP). I was aware of it but I thought it would take a maximum of a few hours to return to normal, but nothing happened. After about 24 hours no peer e no pending Tx.
Currently, I have tried restarting again (with another IP) but after almost 24 hours and “glad you are stay with us” in the topology file, I have no incoming connection and no tx in pending. I have not changed any settings in the files, the port is correctly open, and the firewall rules seems are correct

Ticker CLINK


Status: active

To                         Action      From
--                         ------      ----
22/tcp                     ALLOW       Anywhere                 
6000/tcp                   ALLOW       Anywhere                  
22/tcp (v6)                ALLOW       Anywhere (v6)            
6000/tcp (v6)              ALLOW       Anywhere (v6)   

Node Port


Node ( 2 incoming are BP and other Relay )
The node has been active for 30 minutes because I tried to reboot it before 24 hours
image (last 4 )

{ "resultcode": "204", "datetime":"2023-01-25 06:19:40", "clientIp": "x.x.x.x", "iptype": 4, "msg": "glad you're staying with us" }
{ "resultcode": "204", "datetime":"2023-01-25 07:19:43", "clientIp": "x.x.x.x", "iptype": 4, "msg": "glad you're staying with us" }
{ "resultcode": "204", "datetime":"2023-01-25 08:19:45", "clientIp": "x.x.x.x", "iptype": 4, "msg": "glad you're staying with us" }
{ "resultcode": "204", "datetime":"2023-01-25 09:19:47", "clientIp": "x.x.x.x", "iptype": 4, "msg": "glad you're staying with us" }
{ "resultcode": "204", "datetime":"2023-01-25 10:19:54", "clientIp": "x.x.x.x", "iptype": 4, "msg": "glad you're staying with us" }

Any idea of what i do wrong??
Thank you


wait more time, usually the nodes are restarted once/24 hours… once restarted the nodes will connect to your server.


1 Like

Thank you for the quick response! I’ll wait a more time :smiley:

but, who are the 2 IN peers?
BP and other relay right? BP and other relay have tx processed? If yes then check for this node if inside config.json you set to true TraceMempool.


Yes, the two incoming connections are the other relay and the bp. Currently, there are no processed transactions but TraceMempool is set to True on all three computers :slight_smile:

1 Like

Now working, incoming peer and transaction increasing on all three pc
Thanks for reply :slightly_smiling_face:

1 Like