Payment.addr no longer working to fund new Pool certification

Hey guys! I created my pledge wallet back in the Shelly era, and extracted the payment.addr using step 10 of this guide the Mnemonic Method

My question is, do i need to run this script again with the allegra era cardano cli? (1.24.2) Will it give me updated and accurate keys that were created in the shelly era so I can send payment to submit a new Pool certificate? The address I used before shows the transactions but no longer has a balance to submit the transactions. Hence why I believe I might need to create another payment address

Rotating KES and Operational Certificate does not involve any payment.
So it is unclear what you want to do here.

You are right sorry I am very tired haha edited to be correct. Looking to adda relay to the Pool cert and can’t submit the transaction due to faulty payment.addr used in shelly era

Could you please paste the error you get when you submit or construct the tx ?

Not an error, but when I run this

cardano-cli query utxo \
    --address $(cat payment.addr) \
    --allegra-era \
    --mainnet > fullUtxo.out

tail -n +3 fullUtxo.out | sort -k3 -nr > balance.out

cat balance.out

while read -r utxo; do
    in_addr=$(awk '{ print $1 }' <<< "${utxo}")
    idx=$(awk '{ print $2 }' <<< "${utxo}")
    utxo_balance=$(awk '{ print $3 }' <<< "${utxo}")
    echo TxHash: ${in_addr}#${idx}
    echo ADA: ${utxo_balance}
    tx_in="${tx_in} --tx-in ${in_addr}#${idx}"
done < balance.out
txcnt=$(cat balance.out | wc -l)
echo Total ADA balance: ${total_balance}
echo Number of UTXOs: ${txcnt}

The out balance is 0.

On 11/19 I used the payment.addr in question to register my pool as seen here,

now that same payment.addr won’t work. This is why I think I may need to run the script again. What are your thoughts on it?

The explorer says that the final balance = 0. So all seems in order :smiley:

I don’t think so haha because when I go to fill out the tx.tmp it says missing tx in from the script I ran above

And let me be clear, the Number of UTXOs and Total Ada balance of the payment.addr is 0. So there is something wrong there

Plus when i run the command

cardano-cli query utxo \
    --address $(cat payment.addr) \
    --allegra-era \

it gives me a whole lot of nothing ie this

                       TxHash                                 TxIx        Amount


Basically, I need to do something like this I believe. I have the s and v key for payment I just need to build the address. I think this is the solution, but can you build this on mainnet?

The payment.addr you provided with the explorer link has already been built using the payment.vkey and stake.vkey.
It is just that this address is empty. It does not contains any Utxo. Your output is therefore normal.

Correct so what is the fix for this? Or I guess not a fix since this is expected behavior, but what is my course of action here to get a payment.addr that works.

send ada to it :smiley:

Send ADA to the pledge wallet? That will allow my old payment.addr to be associated with an address?
Update: didn’t work. Sent ADA to pledge and payment.addr still showing no output

SOLVED. I sent a transaction directly to the payment address haha. This is such a janky way of doing things. Thank you so much for your help.

I had this issue a while back. You may not remember but the first script to create a wallet with the numonic phrase was wrong and there was a fix (still is) on the coincreshaw site.
It’s an odd issue. if you send ada to your pledge address, it doesn’t show up on your payment.addr but does add ada to your pledge (like it should)… But the strange part is, if you send ada to your payment.addr address, it also shows up in your pledge (at least in daedalus it does)… I understand that they are two different addresses but for some reason, they both add ada to your daedalus wallet…

I like it this way because now i can keep my payment.addr wallet pretty much empty unless i am sending a payment…

Yeah its weird for sure. I made a note of it and I know the bug you are referring to. I ran their test to see if I was affected but it says I wasn’t but here we are lol. But ya I got it and we are good to go. Hopefully, this will be well archived so I can help people that have the same issue.

Oh, I was not aware that you have been using a scripts collection provided on a tutorial website. Tbh with you, I don’t know much nor use a lot of scripting - I usually generate all my tx and related files by hand, that way I have total control over the logic. It’s tiresome, I agree, but no surprises :sweat_smile: