Pool not listed in Daedalus 3.3.1

Hi I am wondering why my pool is not showing in Daedalus Mainnet 3.3.1 in Windows.

But here I can see it:

The old post didn’t help Pool ticker not showing on Daedalus 2.0.1 - #14 by RobJF

What can I do?

Mine took 24 hours to show up

I tried again to upload my metadata json:

  • I checked the encoding is UTF8
  • Re-caulcated hash and submitted 3 days ago

But I cannot see my Pool in Daedalus by searching “SPRD”.

On the Mobile app for pool IO it shows also no UPDATES which is strange, there should be an update 3 days ago that I changed metadata, not?

Can somebody see the error? here my json:

Is there a way how I can analyze the error?

Change the branch from main to master on github… press raw copy the link and register again the pool with the new link (must be master not main)

If u don’t know how to do it, check my topic … how to setup a pool…


Why makes the branch a difference?
I copied of course the raw link in shorted it for the hash generation.

Tonight I can try it, but honestly I don’t understand why this should make any change?

It will help :wink:

PS: ur ticker is not visible on pooltool.io

Now I will try to update.

Yes it’s strange, on adapools all information is displayed but on pooltool.io only the ID and in Daedalus nothing…

1 Like

I had a similar situation and found the problem by checking:
curl https://smash.cardano-mainnet.iohk.io/api/v1/errors/[YOUR_POOL_ID]
if there are errors preventing your pool from showing up in Daedalus, they should be returned by that. If that returns , then I don’t know what your problem could be.

1 Like

The url link has more than 65 characters (89)


1 Like

I have updated 22 hours ago with the following URL https://git.io/JqWYB So I have changed the branch from “main” to “master” but no change.

But with the answer from @PierreBoudreau I found the error that there is a mismatch of the provided hash:

Very strange I re-uploaded in total 4 times now the metadata JSON seems a problem in my steps…
I copy via pscp the JSON file from my windows to my server and afterward calculate the hash.

Now I will try directly download from my server via wget the file from github maybe this solves the issue…

1 Like

Very strange when I calculate the hash even if I download directly from the same URL like IOHK in the logs then I get always this hash f97f554780ee4f9acfcffb9d6532918ac9cb41beadaf232db21b046713369094

But like in the logs it should be the hash of 5c2acef7f1f081d72020b918cc54bde86977f4c2f8cb6121f2bdbd2a924d0382

Here the logs: https://smash.cardano-mainnet.iohk.io/api/v1/errors/2064da38531dad327135edd98003032cefa059c4c8c50c2b0440c63d

Of course I can just send the transaction with this expected hash but I want to find the source problem.
Why my cardano-cli calculates the wrong hash for the same file?

Here are my versions:
cardano-cli 1.25.1 - linux-x86_64 - ghc-8.10
git rev 9a7331cce5e8bc0ea9c6bfa1c28773f4c5a7000f

Could be possible because u are using a short url?

1 Like

A hash mismatch was what I had also when I looked at the smash URL with my ID. I download the file from Github again and recalculated the hash and resubmitted and it worked for me. I think I had used the original file on my workstation when I had first calculated the hash and maybe there was something changed when I uploaded to Github and re-downloaded. Possibly line endings change by Github? To be honest, I’m not sure I remember exactly the steps I did to get it working. Just had a sigh of relief when I saw it in Daedalus and I went to bed. It was late :slight_smile:

1 Like

They mention also in the official docs short URLs and also cash crew guide:

It’s very strange since I directly download the file via wget to my system and calculate the hash and I get another hash then expected…

I will investigate more, lets see why this is the case…

I used a shortened url also and did get it working. Pretty sure I did not cheat by sending the hash I saw in the error message.

Yes, I know… but something not working

1 Like

I have verified like officaly mentionedhere: Stake pool metadata - technical-docs - Cardano Updates
Following stuff;

  • Metadata information is encoded in UTF-8, and will never exceed 512 bytes
  • The content hash of the JSON object referenced in the URL (if present), should match the content hash in the registration certificate. If there is a mismatch, the pool will not be displayed in a wallet.

My JSON is valid for UTF8 and less bytes, I could not find the issue since my hash calculation evaluates always to something different…

Now, I have uploaded it to my web hostspace and re-submitted the registration with the new hash: http://sprd-pool.org/wp/poolMetaData.json

Now lets see whats happening until tomorrow…

PS: I checked and my json contains in the description some special characters: “(check the website)”. if its not fixed with the web space I will tomorrow try to remove the braces in the string maybe this leads to some errors…

now it’s available on pooltool.io

1 Like

Thanks Alex and Pierre for your help!

Now I am listed finally after 30 days in Daedalus and Pool.io!!

I have no Idea what happened previously but this solved the issue finally:

  • Movied my poolMetaData.json to my web space instead of github
1 Like

I saw this behavior also to another person which tried the short url option…