Stake Pool not showing on Pooltool, daedalus etc


so I have recently setup a new pool thanks to Alex’s guide on this forum :slight_smile: .

I am now able to find my pool on Adapools but not on pooltool or daedalus? What am I doing wrong?

Thanks in advance

Check the pool on

1 Like

also worth to go through on this topic, useful tips to debug such situation:

1 Like


thanks for the quick reply - I think I have the same issue as the post @laplasz has added above:


Seems like my host is reading the file as a json application…

but first make sure that you get errors from the smash server…

Btw -
I am unable to find the pool with the name - but if i search after our pool ID i can find it.

It shows the info but some errors/warnings too - I do not understand why its still showing a hash warning eventhough the file is as-is from the server:

Stake pool registration

Pool pool169mewaur9ma6ffw6x90xhjj0sk9j8yu3ynqz20jh03dj20syqwc found

Margin is 1%

Pledged amount of 9,775.08 ADA matches declared amount of 9,680 ADA


Processed metadata

{“name”:“CARDAZIO”,“ticker”:“CDZIO”,“description”:“ | Our mission is to introduce new users to the Cardano and Crypto Ecosystem by creating e-learning platforms in multiple languages | Join our pool today and help us support childrens education in third world countries.”,“homepage”:“”,“nonce”:“1619561674”}

Metadata hash af9623ea22c62eda613c23553895413f4909e138a4d2aea1b946ada9302db5a7 doesn’t match registered hash 3500e0059e46e1db02b473556f5681b00b27f82e62a1a160ab9400df3d901133

See Get the hash of your file and Generate stake pool registration certificate

Extended metadata missing

Adding extended metadata makes it easier for users to navigate different stake pools. See AdaPools example

Relay node

Check manually that the topology for relay node is configured

Relay node is missing in topology.json

  1. you have a metadata issue - that’s why u can’t find the pool by ticker or name on
  2. u need to run topology updater script once/hour - if u deployed as systemd and pressed Yes for topology updater (only on Relay) in 3 hours, this error should disappear
1 Like

Hi @Alexd1985

Thanks for the quick response.

    • Do I run the topology updater on my relay again? Only once?

you can check if it ran

sudo systemctl status cnode-tu-push.timer

1 Like

Hi Alex,

  1. I updated the topology again on the relay, restartet the nodes and its up and running:

    Does this look ok now?

thanks for the help.

it looks ok, you should see in logs/topology_updater log messages , the message : glad u are staying with us! (after 4 successfully runs)

Thanks for all the help.

So strange - is still showing the same error. Eventhough I have waited more than 12 hours now.
Hmm - do you think it will help if i create a new metadata file? Download a new from the server?

hmm, also u have a long description, I don’t know if this is the reason but try to create another metadata.json with a short description and submit again the certificate.

I just tried to fetch your json file with curl

$ curl
<html><head><title>406 Security Incident Detected</title><meta name='viewport' content='width=device-width'><link href='//' rel='stylesheet'></head><body><h1>406 Security Incident Detected</h1><p>Your request was blocked. Please try again later.</p><hr><p>YIsybSOBZu6Neu9euziEGwAAfgs - -</p></body></html>

same result with wget

$ wget
--2021-04-30 00:23:24--
Resolving (
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 406 Not Acceptable
2021-04-30 00:23:24 ERROR 406: Not Acceptable.

However when trying via browser I got the json file.

the internet says that:
“406 happens when the server cannot respond with the accept-header specified in the request. In your case it seems application/json for the response may not be acceptable to the server.”

I think this should be fixed…

regarding to the topologyUpdate, check the logs of the topologyUpdate script as @Alexd1985 suggested