Stakepool is listed as "Missing" on adapools (Daedelus View)

Stakepool was created a few days ago and everything seems to be ok, but still not listed in Daedelus? Today, I checked in adapools (Deadelus View) and it shows up as Missing. I checked to see if it’s delisted, retired, or showing any metadata errors and it’s all clean. Any ideas?



(I moved this post out of the “operate stake pool” and over to “setup a stake pool”)

Patience, it will appear on daedalus, give it more time.


1 Like

If that’s all it is, I can handle that! Thanks! :smiley:

Is there a reason for the delay between pool creation and it appearing in Daedelus, such as a vetting period or just sheer volume of new pools? I haven’t see an explanation for that anywhere? Thanks again!


Can you see your pool now?

I can see it in Yoroi, but it’s still not showing up in Daedalus. I did install the Daedalus update this morning and restarted (4.0.5). Very frustrating.

Ok, lets wait what happens after starting new epoch today

1 Like

Nope. Still not in Daedalus.

But, did u checked on daedalus wallet?
My pool was for months on with missing status… but on daedalus it was fine

Anyway, try to remove the character ‘ from your ticker; I remember I had this character and I removed it because in metadata.json from server it showed as a strange character


So - since I had the same issue recently I just went through again checking the pool registration in the SMASH server - Daedalus is fetching the info from there.
And at least there is an error now:

curl ""

[{"time":"09.04.2021. 18:02:20","retryCount":1,"poolHash":"34082a7853367db1937b897cd853d23413287a2e544bad617f0ea7d125727036","cause":"URL parse error from poolId '77bacb7cb880adb3174299f0940dd2a0380beb376ee412e650172f94' when fetching metadata from '' resulted in :","poolId":"77bacb7cb880adb3174299f0940dd2a0380beb376ee412e650172f94","utcTime":"1617991340.649667s"}]

Also there is another query for getting the registered metadata - which in your case it is empty:

--2021-04-16 11:57:23--
Resolving (
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2021-04-16 11:57:23 ERROR 404: Not Found.

So just checked the ledger state on blockchain and there you have - the URL of the metadata is wong - https:// prefix is is missing

 "77bacb7cb880adb3174299f0940dd2a0380beb376ee412e650172f94": {
                        "publicKey": "77bacb7cb880adb3174299f0940dd2a0380beb376ee412e650172f94",
                        "cost": 345000000,
                        "metadata": {
                            "hash": "34082a7853367db1937b897cd853d23413287a2e544bad617f0ea7d125727036",
                            "url": ""
                        "owners": [
                        "vrf": "884cc813871b33d7dbb8832a4117a77bd2ceb9015bc4a485c8fdca44ed6b7c9f",
                        "pledge": 1255555555,
                        "margin": 2.0e-2,
                        "rewardAccount": {
                            "network": "Mainnet",
                            "credential": {
                                "key hash": "3b80a5f6cde5f69ae40f314247c26eb8442601e1cbc4aed44e27bd7b"
                        "relays": [
                                "single host name": {
                            "key hash": "3b8066c8915889ca058ec3da4f7b833bc8d0bd69021897867be69035"

so re-register your node with corrected metadata URL:
Hope that was the issue!

How to debug smash server:

@Alexd1985 @laplasz thank you both! Will be adjusting the registration and trying again shortly. Crossing my fingers!

I had a thing typed up, but found something. Will report back in a bit.

@Alexd1985 @laplasz The plot thickens. The file is accessible, so why would it be telling me it’s not?

curl “

[{“time”:“16.04.2021. 15:36:22”,“retryCount”:4,“poolHash”:“b379431caa21a3c1fba54a161a5a749c926c00a3827d9187edfcaa805bf69133”,“cause”:“HTTP Response from poolId ‘77bacb7cb880adb3174299f0940dd2a0380beb376ee412e650172f94’ when fetching metadata from ‘’ resulted in : 403”,“poolId”:“77bacb7cb880adb3174299f0940dd2a0380beb376ee412e650172f94”,“utcTime”:“1618587382.424921s”},

Updated ledger info:
“77bacb7cb880adb3174299f0940dd2a0380beb376ee412e650172f94”: {
“publicKey”: “77bacb7cb880adb3174299f0940dd2a0380beb376ee412e650172f94”,
“cost”: 345000000,
“metadata”: {
“hash”: “b379431caa21a3c1fba54a161a5a749c926c00a3827d9187edfcaa805bf69133”,
“url”: “
“owners”: [

Something is not working… I can’t find the pool on or

It’s there: pooltool

Poolvet is down though. I checked mine and thought it was broken, but tested a number of others and any pool I searched for was failing.

Edit: Poolvet is back up!

1 Like

@Alexd1985 @laplasz

How I verified the hash:
cardano-cli stake-pool metadata-hash --pool-metadata-file poolMetaData.json > poolMetaDataHash.txt cat poolMetaDataHash.txt

Also ran this to make sure:
$ wget
Saving to: ‘poolMetaData.json.2’
poolMetaData.json.2 100%[==================================================================================================================>] 157 --.-KB/s in 0s

$ cardano-cli stake-pool metadata-hash --pool-metadata-file poolMetaData.json.2 > poolMetaDataHash2.txt
$ cat poolMetaDataHash2.txt

Same hash. I then moved the poolMetaDataHash.txt file over to my air-gapped machine and generated the pool.cert. Not actual values below, except for the metadata

cardano-cli stake-pool registration-certificate 
    --cold-verification-key-file nodekey.vkey 
    --vrf-verification-key-file vrfkey.vkey 
    --pool-pledge 100000000 
    --pool-cost 345000000 
    --pool-margin 0.20 
    --pool-reward-account-verification-key-file stakekey.vkey 
    --pool-owner-stake-verification-key-file stakekey.vkey 
    --pool-relay-port 6000 
    --metadata-hash $(cat poolMetaDataHash.txt)
    --out-file pool.cert

Generated the transaction, fees, back to air-gapped to sign the transaction, back over and send it.

I think this is some kind of SSL issue… but checked with browsers and wget and got the json file. so I have no idea what went wrong - probably this is your web server and there could be some certificate settings issue - but everything looks ok.
So I think now you need to contact IOHK support to explain this behavior…
Just submit a ticket with your findings and within 1 day they will reply


Submitted. I’ll post when they respond. Hopefully, it’s something simple and avoidable for someone else!


Anyone know how long it takes for IOHK to respond? Three days now. :confused: I know they are busy, I’m just impatient. :slight_smile: Updated to 1.26.2 in the meantime! haha

I’m about ready to scrap the entire project and start over. I have people waiting to stake to my pool, but it’s been over 5 days with no response from IOHK. I’ve missed another epoch because I can’t get a response from them. Anyone have a suggestion?

strange I always get responses within a day…
Have you got an automatic response about your request was registered?

your node is ready - ask your friends to delegate with other wallet - like Yoroi…

1 Like