Stakepool not showing in Deadalus - possible errors checked

Hello dear community,

after registering our Stakepool AGMOS, I’ve used the wrong hash at first. After updating this error, the metadata shows correctly on Pooltool. But still, it won’t show up in Daedalus.

After checking if my pool is because of some reason retired,

curl --silent “” 2>&1 | grep -o 4630cc9a12c0742d779dafb0d0b92fa485481d92a1fbb27fd6f66bf2


curl --silent “” 2>&1 | grep -o 4630cc9a12c0742d779dafb0d0b92fa485481d92a1fbb27fd6f66bf2

or shows any errors

curl “

I didn’t find any results. Nevertheless, checking whether SMASH has picked up our pool doesn’t deliver any results as well, fetching from SMASH using the following URL:

curl -X GET “

Can someone provide me with information or further clues why our server still doesn’t show up in Daedalus? It can’t be about time, as we have registered the pool almost two weeks ago.

I appreciate any tips and explanations!
Thanks in advance fellas!

1 Like

Before you do anything, resynchronize your database in the Daedalus Wallet. Just set it to “None - fetch the data …” and then back to the SMASH server of IOHK.

Your pool is not registered on the SMASH server from IOG. Otherwise, this happens very quickly. Possibly there is a certificate error or an error in the metadata.json…

If everything works correctly the command will give you a message in json format.

curl -X GET

Output Example:

    "name": "Crypto Dredge Stake Pool",
    "description": "A highly secure Staking Pool for Cardano.",
    "ticker": "CDA",
    "homepage": ""

Hey there, thanks for your quick response!

If there was an error with the metadata the following command would show errors, right?

curl “”

and, additionally, Pooltool is able to fetch all the metadata information. I made sure that the hash matches exactly the metadata after formatted by git under the domain So all of this works fine.

While creating the certificate I have registered two owners, supposedly without errors. What kind of errors could occur with the certificate and how would I detect them? Also, wouldn’t an error in the certificate lead to a non discovery by Pooltool as well?


This is really a bit difficult to say. Did you also download the metadata.json from GitHub and check if the hash is correct?

If you are looking at

and there are problems with the certificate, this will also be displayed with a yellow exclamation mark "! But this is not the case. In rare cases it happens that the IOG SMASH server sometimes needs a manual push. For this you would have to contact the github project and ask if there can be looked at.

So what I can say for sure is that your pool is registered on the SMASH server:

    "poolId": "4630cc9a12c0742d779dafb0d0b92fa485481d92a1fbb27fd6f66bf2"

Please go through everything again and see if you have really transferred all certificates correctly and you have also taken over the correct hash. At you can also look at the administration which HASH is currently the right one. Otherwise please ask in the Git project whether IOG can look if everything is ok with the SMASH server.

1 Like

Thanks for your advice and for looking into it!

I’ve downloaded the json from GitHub and used its hash. Additionally, the same hash shows up on the management site in Pooltool.

I’ve rechecked all the necessary steps + certificates and if I’ve made a mistake I don’t see it. I’ll ask IOG on the Git project for further help, thanks!

Ok, then please ask there. Good luck!

1 Like

I have the same issue - could you manage to fix yours? Another question - where did you find this query? I mean was that a tutorial or an official documentation about SMASH?

curl -X GET “

The documentation can be found here - SMASH — SMASH Documentation 1.0.0 documentation
I’m currently looking into the issue and will report my findings.

In the meantime, you check here - Stakepool Metadata Aggregation Server (SMASH) — SMASH Documentation 1.0.0 documentation

You will see a bolded info - “This shows all the errors for the pool from a day ago.”, which is the default and will be changed to show the last 10 errors since this seems to be confusing.
You can use the format curl --silent to check the errors.


I am having the same problem. My metadata checks out ok on your smash server, it checks good on is, the yoroi mobile wallet is finding my pool (but after staking it says unkown pool), but deadalus wallet is still not finding my pool at all - so my delegators cannot stake with us = SANTO Pool ID

curl --silent
gives back this:
{"time":"14.06.2021. 00:59:10","retryCount":1,"poolHash":"3dd00654699326887e3dd25d7d488bf4addd875e71136f32c7aae7cfea0bf0b3","cause":"Offline pool data from poolId '9837e1eca79504f57acd4e12f2db93ee04a76bca308cae61a6ee205a' when fetching metadata from '' exceeded 512 bytes.","poolId":"9837e1eca79504f57acd4e12f2db93ee04a76bca308cae61a6ee205a","utcTime":"1623632350.177747s"}

still having issue?

What does this mean?

seems that file size is bigger than 512 byte - but it is actually 149 - just checked.
But still the pool not visible in Daedalus?

yoroi wallet finds pool but display unkown after staking

just checked again the length of the metadata and seems fine now - how about Daedalus? is that showing your pool?

I have to reinstall daedalus i think. It keeps crashing

1 Like

I moved Daedalus to a faster computer and restored but my pool still does not find.