Pool Name and Info not showing

Hello together,

I’m operating a stake-pool and found out, that my metadata is not showing on Adapools, although I was able to delegate to my pool through daedalus, where I found it under the Ticker I set.

I tried ten times now to update my pool-info by registering a new cert on the blockchain, each time I paid the fee and it showed on adapools that my pool info was updated, although it omits my pool name and website.

pool id: 7472e0960f7e59253dff9ddd0245b69a8898b51e103dd0c95aea9ac6

I followed the “registering a stakepool with metadata” instructions to renew my info, I think this is the way to update my pool meta data. Am I missing something?

Here are my Json files:

I have absolutely no clue, what to try next. Hope you people have an idea :frowning:

The node itself is running fine and processing Tx’s, but the metadata is not showing.

Does it matter which version of cardano-cli I’m using?

It should show up in pooltools, so registration should have been successful.

adapools will take some time to appear.

sorry. I use Google Translate.

1 Like

I see it on pooltool and in Daedalus - it looks good

1 Like


thank you very much for your replies, this is good to hear.

Is pooltool down at the moment? On the main page pooltool.io it says “active pools: 0”

How long did it take for your pool on adapools? It’s been almost a week now, and it is not listed.

Did you create the hash metadata in the new json file before creating pool.cert?

cardano-cli shelley stake-pool metadata-hash --pool-metadata-file stablepoolMetadata.json > poolMetaDataHash.txt

Yes, I regenerated the hash after modifying the json and put the new hash in when generating the stake pool registration certificate.

The pool is showing fine on https://pooltool.io/pool/7472e0960f7e59253dff9ddd0245b69a8898b51e103dd0c95aea9ac6/blocks

All I see on adapools is still this: No name, no website.

Any ideas?

i want to know this too. anyone know?

You may want to reach out to adapools on this one

My first (wildcard) hunch is your meta file isn’t being read by adapools for some reason - perhaps either whitespace needs cleaning up or maybe because your meta file is hosted via http, and not using SSL (https).

Thank you ADAfrog, this definitely sounds reasonable, I’ll try to put the metadata on github.

Went through the reg process again, this time metadata (https://git.io/JUWwd) and extended-metadata (https://git.io/JUWwD) are hosted as gist, with a shorted url.

Still no luck with adapools, name and info is not showing.

Adapools is not really answering my request, just some replies if I registered my stakePool at all, which I obviously did.

This is really frustrating…

Now you’re not showing in Daedalus either.

During pool registration you should limit the length of your meta URL to 64 characters I believe.

Well, seems I was too fast with my frustration, now I’m listed fine on adapoos. Thank you ADAfrog, I think it was really the missing https!

Am I now again visible in Daedalus?

I used a git.io shorted URL, is this not the way?

Could you be so kind to re-check if you see my pool now in Daedalus? Then the question would be solved :slight_smile:

I know operators have had issues using URL shorteners.

Unfortunately I still do not see it in Daedalus

Ok thank you, I’ll look for a url solution with shorter URL’s and report back if it works.

At least adapools is accepting my extended metadata now, thanks so far.

Now I used jsonkeeper to upload my json files:



Am I visible in Daedalus again?