poolMetaData.json only in html-format

Dear Support-team,

I just setup my first Cardano pool. So far so good, but my Pool meta data does not correct show up in pooltool.io. Just the ID is stated and no Ticker, name, and so on…

Followed carefully the procedure from CoinCashew

But as soon as I run “wget -O poolMetaData.json https…” from github the built file content is html format. I tried the shortend link as well as full length link (< 65 char) but no change. As soon as I open the downloaded file its in html.
I assume this cause a hash difference and pooltool refuses to show up my data.

Any idea?


check your pool on pool.vet (by pool ID)

And btw - what is your pool id?

Hi Alex,

thanks for fast reply!
Instead of github I used jsonkeeper.com → this was the fix! From there I receive text only and it works now!

Anyway, thanks also for the hint to pool.vet.
In general all good except “Relay node … is missing topology.json”
I am wondering why? I set it up and my relay-topology_pull.sh is updating the file correctly. I got 20 peers for OUT on my relay and 4 peers for IN on my relay. So I thought everything is fine. However my Processed TX does not increase. It stays at 0 :frowning:
any idea on this?
Why shall I mention my “relay-DNS” in the topology.json?
As I understood the relay-DNS must be mentioned in the BP topology, right?


Yeah a little bit misleading - the topology.json which is mentioned is the global file where all the relay addresses are stored.
wait 2-3 hours more and your address will be listed as well…

storing json files in github also working - have you used the raw format when created the link to your json?

give it time, it’s not so relevant if you have OUT/IN peers and u are processing transactions… in time it will be added
it is important to run topologyupdater script and to receive the glade u are staying with us message (logs → topology_updater_lastresult or something like this)

if u are receiving the message above and still no processed tx even u have IN peers other nodes than yours then check in config file if u have TraceMempool=true


Hello @Durianfreak,
I got the impression you mix things together. No offence, maybe I am wrong.
Generally your BP is hidden to anyone except your relays. Topology.json file is fixed and contains only your relays.

Your relays are open to the outside world and need IN connections from outside in order to process TXs’. Your 4 is too little.
To let everyone know the relay exists and is online, you need to run topologyUpdater.sh once an hour. To keep your relay connected to your BP you have fill in your BP into the CUSTOM_PEERS inside the script.

If you have all set up right, after 4 hours your node is registered and you should see the number of IN connections going to appx 20 and your TXs’ increasing.
To restart your relay once a day is a good practice to refresh your OUT connections.

Alex, Triton,

thanks for your help!
I made a big step in the right direction. The only warning I get from pool.vet is my missing extended meta data (which will be my next action). But everything else is green!

However, there are still some things not clear for me. I hope you can help to clarify this and sorry for these kind of noobish questions:

  • within the topologyUpdater.sh on my relay I put the DNS from my BP as Custom_Peers and the DNS from my Relay as Cnode_Hostname

  • in relay-topology_pull.sh I set the DNS of my BP as Blockproducing_IP (hope DNS is working)
    → the mainnet_topology.json shows me several peers from all over the world but my BP is not listed there. Is this correct? could you please confirm my definitions are ok

  • Currently I am seeing 20 OUT- and 8 IN-Peers on my Relay and 1 OUT and 0 IN-Peers on my BP

  • On Relay: processed TX are increasing constantly and Mempool TX/Bytes is also changing
    On BP: TX stay all at 0
    → is this the correct setting? I though the BP has to process the TX, however my relay does…

Here are two screenshots from my Relay and BP:


is not right, you must see the relay to IN peers on Producer as well.
In your PRoducer topology file did u used the IP address or DNS of the Relay?
also did u added the Producer DNS name to custom peers in topology updater script; and also delete # from the begining…?

you can try from your relay

telnet producer_dns 6000
telnet producer_ip 6000
check which is working and says connected


btw I think this is the topology.json what pool.vet is checking

1 Like

I used my relay-DNS in Producer topology file as well als producer-DNS in customer peers and there is no # infront of it.

From relay:
telnet producer_dns 6000 as well as telnet producer_ip 6000 are both replying connected.

my relay is listed on pool.vet correctly.

its just strange why my In-&-Out-Peers are not correct showing up. No clue what to configure differently…

Which machine should process the TX is it relay, BP or both?


Which machine should process the TX is it relay, BP or both?


Are both synced right?
also did u used relays.mydomain.com,3003 instead of : to separate them… (the latest topology updater use, # Additional custom peers to (IP,port[,valency]) to add to your target topology.json
# eg: “,3001|,3002|relays.mydomain.com,3003,3”)

also try to add in topology updater script the valency 1 (I am not sure if default is 1)
Try to restart the relay

You should be ok running the topologyUpdater script every hour. It will generate your actual topology.json ( or mainnet-topology.json). Check that the file if it contains your BP IP or DNS with a correct port and restart the node.

You should not need to run any other script. What is relay-topology_pull script doing? Maybe it is messing things up.

he is not using cntools (follow another installation script) and he can’t use topology_updater… .he’s using another script which basically do the same job

I understood he runs them both, which could be the issue. I do not know the other script, maybe it overwrites the topology.json without placing the BP address inside. After all, the topologyUpdater works well even without cntools, so it would be my first choice.