Problem closing down my pool


I would like to ask for some help this time, shut down my pool.

Almost a month ago, I decided to shutdown my pool, and i followed an online tutorial I found on this very same page. Everything seemed ok, and i had to wait for 2 (if not mistaking) epoch (the current one back on that date, and the next). So i did, but nothing happened, the pool is still up, and i did not receive my funds back.

So I thought, I must have done something wrong, so I went ahead and try a different guide (cant remember right now which, although i could send you info, if needed), but then right at the end of the tutorial, i get the following error:

Command failed: transaction submit Error: Error while submitting tx: ShelleyTxValidationError ShelleyBasedEraAlonzo (ApplyTxError [UtxowFailure (WrappedShelleyEraFailure (UtxoFailure (ValueNotConservedUTxO (Value 0 (fromList [])) (Value 1800009695 (fromList []))))),UtxowFailure (WrappedShelleyEraFailure (UtxoFailure (BadInputsUTxO (fromList [TxInCompact (TxId {_unTxId = SafeHash "1c2bf89aa2fb9bd53fc8f9116723323fc85a60a530d0353e07b2788b5dd0a0b8"}) 0]))))])

I have no idea what I am doing wrong but i really need to close the pool so i can put my ADA on someone’s pool for delegation.

Thanks so much for any help you might give

First, you need to create the stake pool deregistration certificate, like I am explaining in the tutorial here:

Then, you need to submit the certificate in a transaction like here:

(but only the deregistration certificate in your case).
Don’t deregister the stake key for the rewards wallet before receiving and withdrawing the 500 ADA deposit.


I’m almost sure I already did that, but I might have something wrong, so I will follow your guide and let you know

If you post the stake pool ID, anyone can check if your pool is retiring or not. Without any information, you are the only one who can check.

cardano-cli query pool-params --mainnet --stake-pool-id <pool_id_hex_or_bech32>

This will take a few minutes to complete, and at the end of the response you will see if the stake pool is retiring or not.

1 Like

I have used your command as follows on the Producer node:

cardano-cli query pool-params --mainnet --stake-pool-id pool1qjv6z4enegjdyfuf25tmjzng0uva5u7epsm7whm09jc0ytja8ft

And I get the following error:

MuxError MuxBearerClosed "<socket: 11> closed when reading data, waiting on next header True"

No idead what does that mean, any clue?

Hi @Andres_Molina_Perez,

The copy of the blockchain on the Producer may be corrupt. To fix the issue, for example, see Fixing a Corrupt Blockchain - CoinCashew To save time, you can try copying the db folder from one of your relays, presuming that the db folders on the relays are not corrupt.

Losing another stake pool is always a sad loss for the Cardano community. Keeping an existing pool is always easier than gaining a new one. If you want to see more done to help pools such as yours survive and thrive by doing more to grow the community of delegators for example at the governance level as we are now in the Voltaire era, then perhaps consider the following CIP draft: cardano-improvement-proposals/ at main · paradoxicalsphere/cardano-improvement-proposals · GitHub

I wish I can keep the pool up, but after a long time, we did not manage anyone to join and there seem to be plenty of pools these days, and unfortunately I can’t cope up with the costs.

Probably your node crashed during the query.
Your stake pool is not retiring. You need to do again the retiring procedure.

    "futurePoolParams": null,
    "poolParams": {
        "cost": 340000000,
        "margin": 3.0e-3,
        "metadata": {
            "hash": "1a855456dbd78350f60355dacc2b08c11179030b1e820daf9cd9024e96c698c0",
            "url": ""
        "owners": [
        "pledge": 1750000000,
        "publicKey": "0499a15733ca24d227895517b90a687f19da73d90c37e75f6f2cb0f2",
        "relays": [
                "single host address": {
                    "IPv4": "",
                    "IPv6": null,
                    "port": 6000
        "rewardAccount": {
            "credential": {
                "key hash": "d5a152e8425ef701881e4f2b5b002657aff1a58ac45845758975a474"
            "network": "Mainnet"
        "vrf": "6e9df5e0880f2031044adc65fd6139ac08b9871e698221d2f05807c6bfbac1da"
    "retiring": null

Following the coincashew guide (Retiring Your Stake Pool - CoinCashew), first steps says:

startTimeGenesis=$(cat $NODE_HOME/shelley-genesis.json | jq -r .systemStart)
startTimeSec=$(date --date=${startTimeGenesis} +%s)
currentTimeSec=$(date -u +%s)
epochLength=$(cat $NODE_HOME/shelley-genesis.json | jq -r .epochLength)
epoch=$(( (${currentTimeSec}-${startTimeSec}) / ${epochLength} ))
echo current epoch: ${epoch}

But on my producer node, there is no shelley-genesis.json file BUT, mainnet-shelley-genesis.json file.

Although everything seemed to work fine if i change that command adding the word mainnet to such file route, when I try to launch the last step:

cardano-cli transaction submit \
    --tx-file tx.signed \

It throws back the following error:

Command failed: transaction submit  Error: Error while submitting tx: ShelleyTxValidationError ShelleyBasedEraAlonzo (ApplyTxError [DelegsFailure (DelplFailure (PoolFailure (StakePoolRetirementWrongEpochPOOL 364 383 382)))])

As if were trying to launch the 364 epoch and not the 383 (but I’m pretty sure I did put 383 when creating the files and signing)

Did you put in all three epoch numbers? 364 383 382? I think you only need to select the single epoch you want to retire it in.

I only used one, that error is saying that the epoch i used is the first on the list (which I did not) then the earliest exit epoch and the actual epoch if I’m not mistaking

Maybe you are trying to submit an old transaction, not the one you created now?
You can check the tx.signed file with cardano-cli transaction view --tx-file tx.signed. You will see the transaction details.

Sure is not that, I did it twice, and I deleted all the previous ones in the folder. Don’t you think it might have something to do with the mainnet-shelley-genesis.json on my end instead of shelley-genesis.json stated in the guide?

it seems there must be some corrupted file somewhere in the process, because “funny” enough the stated 364 epoch stated in the error is the epoch I used when I first tried to retire the pool, which it somehow failed. And now it keeps saying that.

Is there any way to force check/redownload/sync everything without loosing anything?

As long as you have the keys, you don’t lose anything, you can even destroy the servers.
Is your node in sync?
You can check with cardano-cli query tip --mainnet.

Well, effectively it is desynced since 364, so how can I force re-sync?

This is the result of your command:

cardano-cli query tip --mainnet
    "era": "Alonzo",
    "syncProgress": "95.37",
    "hash": "c58a24ba8203e7629422a24d9dc68ce2ed495420bf40d9dab124373655161a20",
    "epoch": 364,
    "slot": 72316796,
    "block": 7791698

Might the problem be that for some reason producer and relay has “disconnected”?

Your node is still in Epoch 364. We are now in Epoch 382. Are you running cardano-node 1.35.3 or 1.35.4? If not, do it.

Ok, I’m trying to update it, and it is giving a lot of trouble, as the server seems to be a bit… ffffffffff up, so I’m thinking about reinstalling the whole producer node again, so I can finally do what I need. Is it an issue to reinstall a clean Ubuntu and reinstall the producer node in it? If not, then would you give me some advice of files and or configurations I should be sure I do have a back for?

You don’t need to do anything else than download the latest static binary distribution from the Github releases link (, extract it, replace your cardano-node and cardano-cli binaries and restart the service.

I know but im not being able to download the static binary distribution becuase it says that archives folder is full and there is no space. I tried everything to extend the size, move it to a different folder, clear, etc etc etc, but it keeps saying there is no space to download and install