Problem in displaying NFT on pool.pm after minting

Hi all,

I’m currently encountering a problem when viewing my minted NFT on pool.pm. It says token not found as shown here

Here is a sample metadata that I use (but not the one minted) just to show the format:

{
  "721": {
    "7ffce9571e5cedefe84615a37732f9e21817cf146e07a1f139b615da": {
      "test": {
        "name": "T9",
        "image": "ipfs://QmU88xQvKB7m7cyGsTdEWhNs2T5kfgx6rePKWLAa8bYP8L/9.png",
        "mediaType": "png",
        "description": "Testing",
        "files": [ ],
        "src": "ipfs://QmU88xQvKB7m7cyGsTdEWhNs2T5kfgx6rePKWLAa8bYP8L/9.png",
        "NFT_Variants": {
          "AreaLight": "AreaLight_2_0",
          "Cube": "Cube_3_33",
          "Curve": "Curve_1_0",
          "PointLight": "PointLight_2_0",
          "Sphere": "Sphere_1_0",
          "Text": "Text_2_0"
        },
        "NFT_DNA": "2-3-1-2-1-2"
      }
    },
    "version": "1.0"
  }
}

I’m not sure if there is a problem with the metadata format but I’ve already followed the standard and it also works fine when pasting it on the Test Metadata feature of pool.pm.

The minted token also looks fine when inspected on Cardanoscan: https://cardanoscan.io/transaction/e72bb59d196654a2fba70b6de8129564ae36a5b6abe058b8f9886a4a79adbe85?tab=metadata

I’ve already read a similar issue by h1ddenproc3ss but he was able to resolve it by matching policyid on the metadata and the transaction. I checked mine but it was fine as well.

Would very much appreciate any response! Thanks all!

1 Like

use this link and test ur metadata (it’s like a preview before to mint the NFTS)

2 Likes

Hi @Alexd1985! really appreciate the response. However, the metadata is working as it should when I test the metadata (see here)

I was wondering if registering the NFT on the Cardano Token Registry has anything to do with the problem?

should not be any issues

1 Like

If u are searching for asset I see this

1 Like

Yes. I’m confused why the line “containing 721” doesn’t appear in the metadata when inspected in pool.pm but when checked in Cardanoscan, it appears correctly.

Here is one of my nft, you can check and compare

image

or this one

image

1 Like

I’ve tried minting new NFTs but still end up with the same results. I’m also pretty sure my metadata formatting is correct as it matched the one you have sent.

I think the issue is that pool.pm is reading my metadata without the “721” header. When inspected in Cardanoscan, the metadata appears neatly (see here - Cardanoscan)

But when I search my NFT in pool.pm using the fingerprint (asset19a7hjlzwsdpm8g3xnmqeuef3yklq3nfrh8n4uc) and view its metadata, the field containing “721”: is not there (see here - pool.pm)

I can’t seem to figure out why :frowning:

Follow this tutorial and try again (I learnt from here)

1 Like

Hello!

Did you find any solution to this problem? I have the same problem - it seems that pool.pm is not reading correctly the beginning of the metadata.json.

Well this is strange, since I have used the same method for months. The only change is that I use base16 token name as required from cardano-node 1.31.0. I tried to mint the NFT 3 times, always the same result.

  • metadata.json I have used :
  • metadata.json in pool.pm:

Thanks a lot. Martin from CBROS

You can contact @SmaugPool on twitter (the responsable person with pool.pm)

I will, thanks Alex!

1 Like

You have inputted the token name in hex with cardano-cli, but it is still expected in utf-8 in the metadata, whereas you also used the hex format in the metadata. This is why pool.pm cannot find the expected token metadata in the transaction.

You can ignore the missing “721” object in pool.pm in this case, it’s a display only side effect of the lookup error and does not mean anything about the way metadata is read. This will be fixed eventually.

Note that there is a Telegram support group for pool.pm: Telegram: Contact @pool_pm

3 Likes

Perfect! Everything works fine now! Thank you! I will suggest the update of Cardano Developer Portal NFT page - Minting NFTs | Cardano Developer Portal
Kind regards Martin, CBROS pool

2 Likes

Hi all! Thanks for all the response. Sorry it took a while before I could try it out again. It simply turns out I wasn’t using the same token name placed after the Policy ID inside the metadata, a very stupid error indeed :sweat_smile:

I’m glad you were able to fix that immediately @Couder! And also big thanks to @Smaug and @Alexd1985 for always being very responsive and helpful in the Cardano Forums!

I am having exactly the same problem on pool.pm. The metadata first line 721 is cut off and the NFT does not display. Cardano.org tutorial literally just changed now and added:

tokenname=$(echo -n "NFT1" | xxd -b -ps -c 80 | tr -d '\n')

I tried this and the Metadata is still cut off. I am running 1.31.0

Hi! I think it is the same problem as @Smaug mentioned. This command created the $tokenname variable with hex format name. If you proceeded and followed the tutorial so you wrote this hex format tokenname to metadata.json. Just change the tokenname in metadata.json to the “real” (utf-8) name. That worked for me.

1 Like

Hi to all.

I created a pull request in tutorial’s github to add a new variable $realtokenname that will be in utf-8 format and will be later used in metadata.json.

This solution works. I’m not sure if the PR will be accepted, but I wanted draw attention to the problem.

Thanks for the responses… I upgraded my system to 1.33.0 and I retried using the utf-8 format and I’m still seeing the pool.pm cut off the metadata. The first lines of my metadata contain:
{
“721”: {
“feb1b26e84ba62277c559fd33b6732988d836420c63459709b95c9e3”: {
“546573744d696e7431”: {

and pool.pm contains:
{
“feb1b26e84ba62277c559fd33b6732988d836420c63459709b95c9e3”: {
“546573744d696e7431”: {

Appreciate the help. Thanks

Did u did what other guys mentioned above?