Problems with Metadata file

Hi, i started a new pool and have problems with my registration. I put the metadata file in the following location:

https://cardanostaker.de/pool/md.json

/pool is an empty folder

i downloaded it from there, compared the hashes like one should and copyed the hashfile to my airgapped machine.

For the "stake-pool registration-certificate " i used:

–metadata-url https://cardanostaker.de/pool
–metadata-hash $(cat poolMetaDataHash.txt) \

i also tried:
–metadata-url https://cardanostaker.de/pool/md.json \

The Pool is live and running but my metadata-file seems not to be seen.
adastat.net says: The metadata hash is wrong
cexplorer says: Name undefined

when i click on the metadata link in cexplorer it leeds me to an empty webpage with the words “permission denied”. Therefore i added a simple index.htm so that the folder can be accesed but the the link leads to the output of the index.htm instead of the json-file.

Is it possible, that i just have the wrong hostingprovider?

Pool ID: pool1mvk6eup390pja32f2r9fgeus5sr5u8l6x9ver65tf7q76t6309z

Could anybody give me a hint please

Greetz, heikikurti

Difficult to investigate if you don’t provide your pool id…

This would be wrong though, because the correct URL is https://cardanostaker.de/pool/md.json, not https://cardanostaker.de/pool.

Sorry, here is the pool ID:

pool1mvk6eup390pja32f2r9fgeus5sr5u8l6x9ver65tf7q76t6309z

That worked it out. Thank you.

  1. you need the full URL in the cerfificate (including file name). Not mentioned in any tutorial i have read.

  2. there has to be some kind of “activation” in the metadata-files´s URL folder (for example: index.htm). Otherwise the folder will be not be reachable (permission denied) or it will be redirected to sedoparking by my provider (not nice)

The combination of both did the job.

Thank you

Isn’t that obvious? How else would it be known which file to pick?

No, just the url of the file itself must work; it doesn’t matter what happens if you surf to ‘the directory’ itself.

I put ‘the directory’ in quotes, because a path without a filename (with an extensions) can also point to a file, that’s just how HTTP works.

TL;DR: if you do an HTTP GET request for the url you provided, you must get the metadata file.