Rewards showing as zero

Ok, I did what you asked and I am getting "Command failed: query leadership-schedule Error: Error while looking up environment variable: CARDANO_NODE_SOCKET_PATH Error: “CARDANO_NODE_SOCKET_PATH”

I am researching how to properly set this now.

@Alexd1985, I was able to fix the Cardano node socket issue, but now I am getting the following error.

Command failed: query leadership-schedule Error: Failed to successfully decode the current epoch state: DecoderErrorDeserialiseFailure "EpochState (BabbageEra StandardCrypto)" (DeserialiseFailure 37954909 "Decoding TxIx: too many bytes.")

what version did u install?

1.35.0 was installed.

I restarted my BPN last night after the above changes. The BPN stopped syncing. I understand it takes time after a node restart for it to be back to a full sync. But it has never taken this long. Image below is after 10.5 hours using sudo systemctl restart cnode.service

1.35.0 was horribly broken.

On testnet, you should go to 1.35.2.

For mainnet, IOG now says 1.35.3 is okay, but I’d still stay on 1.34.1 until it is tested a bit better.

1.35.3 will not work on testnet due to the breakage caused by the other 1.35.x versions.

If you run a node or even a pool, please follow Telegram: Contact @SPOannouncements and/or IOG's Technical Community.

Thanks @HeptaSean! I am not on Mainnet yet. I wanted to ensure enough testing before I build my production pool. I used Guild Tools to deploy my Testnet node.

I have never upgraded/downgraded a node yet. So this is a great opportunity for me to continue learning.

Any recommendations on how to so this easily?
Do you recommend I upgrade my node to 1.35.2 or should I downgrade my node to 1.34.1 for now to establish a fully functional pool on Testnet before moving to the latest?
if I rebuild my node will my BPN wallet be effected?

I will join the Telegram channel for SPO Announcements. Thank you :trophy:

1.34.1 will not work on the testnet, anymore, because the testnet was already forked to Vasil and that needs 1.35.x. So, testnet should be 1.35.2 and 1.35.2 only, at the moment.

After this chaos has settled a bit and probably after the mainnet has successfully been forked, they will probably rebuild the testnet from scratch. But there should be announcements on that.

Since you are doing the guild guide, I hope you have followed https://cardano-community.github.io/guild-operators/ from the beginning.

To build a new cardano-node version, you will typically follow https://cardano-community.github.io/guild-operators/Build/node-cli/. But, since you need a very specific version, you should replace git checkout $(curl -s https://api.github.com/repos/input-output-hk/cardano-node/releases/latest | jq -r .tag_name) by git checkout 1.35.2. (Personally, I do not know if blindly using the latest release – as the command in the guide does – is such a good idea at all.)

Since you mention wanting to continue to learn, I’d recommend to try to understand what you are doing while following these guides. If you are not already familiar with Unix/Linux, try to learn some of that in parallel. A lot of questions that we get here are not primarily Cardano-related, but often come down to something like: “Which program in the $PATH gets executed?”, “When is which environment variable set by whom?”, “Is your cardano-node socket path set in your .bashrc?”, “Are the files where this specific helper script expects them?” Having a working knowledge of Linux helps a lot with these.

Thank you @HeptaSean for the information, I will work to upgrade my node to 1.35.2.

With respect to the guide, yes, I followed it from the beginning. This is not the only I guide I have used to learn. I have used many to formulate my own internally that I will use when I move to Mainnet. I have landed on theirs since I have re-built my node a few times through my testing.

I am know Linux expert, but know enough to understand what you wrote above. I can humbly admit I still have a lot to learn. Upgrading shouldn’t be too tough, especially the relay. My concern was the BPN’s wallet and pool.

1 Like

Hello @HeptaSean, everything went great. I was able to upgrade both the relay and BPN. Everything is syncing. Thank you for the help.

@Alexd1985, going back to the minting blocks issue. Is there anything I can do to ensure my pool is configured correctly to mint blocks? Do I need to wait for another epoch since my pool was down?

Tools like Cexplorer.io and Cardanoscan look good from what I can tell.

Install cncli

cd ~/tmp
./prereqs.sh -c

then go to scripts folder and run

./cncli.sh sync

wait for the sync to be 100% then stop it and run

./cncli.sh leaderlog

should work by default, if not perhaps u will need to update the path for vrf file inside cncli script

#POOL_ID=""                               # Automatically detected if POOL_NAME is set in env. Required for leaderlog calculation & pooltool sendtip, lower-case hex pool id
#POOL_VRF_SKEY=""                         # Automatically detected if POOL_NAME is set in env. Required for leaderlog calculation, path to pool's vrf.skey file
#POOL_VRF_VKEY=""

Thanks @Alexd1985, results below. Interesting that when running leaderlog, the sync keeps going down. But when I run sync, it says 100%.

I get DB not fully synced when I run status.

how much is the tADA stake?

run deploy-as-systemd and press N for topology updater and for pooltool (there are 2 services, sendmytip and another one… send blocks or something like that) and yes for cncli and the rest… then restart the node and check the sync process

sudo system | grep cncli

then with sudo systemctl status (sync service)

this way it will be always 100% synced and it will check automatically leaderlog

The total tADA staked to the pool is 29.49k. I have 3 testnet wallets staking ~3.5k each. The pledge is 10k. The BPN wallet currently has 18.9k tADA staked.

I did the above without issue, but was still not able to get leader log to fully sync. I then renamed guild-db to guild-db.old and restarted the cncli service. I believe that did it, now the sync continued to grow and reached 100%. Does this mean my pool could be selected to produce blocks on Testnet?

Perfect, u can delete the folder renamed… now, the stake is to low to create blocks, open another tipic and ask for someone to send some tADA to u to ur pool address or to stake to ur pool,

Cheers

Thanks @Alexd1985 really appreciate all the help you provided. One last question, what are you recommending for a total staked amount to produce blocks? 100k? I only ask to understand the minimum requirement I am trying to meet.

-1,2M for an average ~1block/epoch

Hi Mate, i hope you are doing well.
i have fixed the pool certificate issue by cntools stuff.

now after two epoches, i still did not received no rewards

what went wrong ? the ticker is ITSYS

1 Like

Understand… in which epoch did u fixed the pledge not met error?