Shelley testnet pool - good peering, still no TXs processed

Hello guys,

I have successfully set up a new stake pool on the Shelley testnet (ticker SMPRF). I believe all is working fine and my only concern is, that the “TXs processed” counter is not incrementing and also the Memory Pool graph is a flat 0.

My relay node is registered in (, TCP 3001 is open from any ipv4) and based on the LiveView I have successfull peering with 66 other nodes on the network.

I have looked at the logs in SimpleView but couldn’t find any issues in there. Could You please guide me in the right direction where else to look for clues?

Much appreciated, cheers.

Is this occurring on the block producer or the relays?

Did you start your nodes with host-addr Are your relay ports open to external connections? Is your block producer open to your relays? Are your block producer and relay nodes mutually networked via topologies?

I would start with using a web-based port checker tool to see if your relay ports are open externally.

Your friend, FROG

Hello ADAfrog,

thanks from your reply, please see the answers below.

  1. This is occurring on the BP and relay node, both are displaying TXs processed 0.
  2. I did start my noder with host address (even though I have only 1 NIC up on these servers, so that wouldn’t make a difference). In netstat my relay node is listening on The BP is open to my relay (ufw allow from relay IP). The BP and the relay are peering via topologies (this can be confirmed from the Peers list as well).
  3. I have already checked if the relay port is open from the internet and it is.

@ADAfrog is it possible, that my problem is related to not using any automatic topology push/pull scripts on my relay node? I have just statically configured my testnet-topology.json and that’s it. Thanks.

UPDATE: today after 3 days my nodes have started to process transactions. I haven’t changed anything. Maybe I needed to wait for other peers to add my relay address to their own topologies?


That’s a possibility but it seems unusual - your relays should have been included in IOG topologies within 12 hours of pool registration (result of registering your relays by including them within your pool reg cert).

Usually I see transactions process once I have bidirectional connections configured between block producer and relays, but my relays are already well connected.

1 Like

I wasn’t even aware of this feature - the publishing of testnet pool relay info. Is that done through the blockchain via setting up your pool, or must you do it outside it, manually entering the info into a website, for example?
Finally got my pool up and running on testnet yesterday, ticker and all.

I see the answer now: “That’s a possibility but it seems unusual - your relays should have been included in IOG topologies within 12 hours of pool registration (result of registering your relays by including them within your pool reg cert).”

I guess I still have to wait a bit.

Hey FROG! Does starting with private IPs for nodes not work in general ;e.g.,, and if so, then should you use “any address or” for your nodes’ start-up commands/scripts?

I’ve change the source host addresses on my core and relay node to “any”(, and restarted the hosts, but don’t know if this will clear the issue. Do you think I should re-register the pool with the new hosts start up configurations ( I don’t know if this would work since my ticker symbol shows up with no problems, but not my relay info for the general public to see.

I use external ips when starting my nodes and they work fine - this has no effect on registration so no need to worry there

1 Like

I got confused with this notation --> I thought the 0s were wildcards so that means any network address. It’s the opposite I’ve come to find by reading online…it means this host on this network - which is more general than which mean this host only accessible to this host, independent of any network I suppose. Thanks again for the help.

1 Like

My laptops are on local LAN, not in the cloud. I’ve been using private IPs for local network node start-up command and for relay topologies.
I tried using external network IP for my node start-up commands and relay topologies, but it gives me subscription errors. So now I’m using for my start-up node commands and private IPs for my network topologies.
I’m trying to get the external IP involved somehow so that the IOG relays will pick up my pool topology data for others to see and add to their topologies.

Hey guys! My testnet pool relay info has finally gone public! What a relief.

This is my set up:
Two laptops on a home LAN - one relay and one core - over wi-fi.
Using private IPs for both host run commands/scripts and both testnet topology files.

The only odd thing is that when I submitted the pool registration certificate, I only have one relay, so I specified the relay’s public IP and port 3001, but in cardano’s testnet pool peering list, my port shows up as 3000, so I don’t know why the port got changed when I still have the actual command/file I used when registering the pool, which specifies my relay port as 3001, not my BP/core port of 3000. Does anyone have any ideas what went wrong and how to fix this? I did register my pool from my core, but the file info used to register the pool was only about my relay. Anyway, my thought is just to re-register the pool relay with the port 3001 again.

It was four days ago when I registered that pool, so it definitely took some time for it to show up on the peer list, or maybe some subsequent changes I made to the host and topology files triggered the listing - I don’t know.