Slot leader but not adopted?

Thanks Radar

It looks like wrong vrf

I just generated new vrf for rotating my kes. Do i need to register the pool again
with the latest vrf???

Hmm I think yes

But I understood it will take 2 epochs?
But why u regenerated the vrf?

for some reason those keys had different creating date on them. OR i can wait until I want to update the pool and I will use the latest vrf.

What you think?

Hello everyone!

I am encountering this exact same issue but unable to figure out what is actually wrong. I would greatly appreciate if I can get some help resolving this issue.

Executing “sudo journalctl --unit=cardano-node -g InvalidKesSignature” on my block producer node shows the following.

This is the second block that was not adopted for which the pool was the leader and the logs reflect the same error both times.

Thanks in advance!

Executing “cardano-cli text-view decode-cbor --in-file node.cert | grep int | head” shows me the following. This is the fourth KES rotation and the number in the below screenshot seems to match it.

image

Finally LiveView shows as below

image

did you find solution for this issue? Even I am selected as a Leader but having that same error. If its resolved please share the solution here.

can u share the error?
and the ticker of your pool?

thank you

Hi @Alexd1985, My ticker is AQN and the error is pasted below:

`[2022-01-19 01:42:28.43 UTC] fromList [("val",Object (fromList [("kind",String "TraceForgedInvalidBlock"),("reason",Object (fromList [("error",Object (fromList [("error",Object (fromList [("failures",Array [Object (fromList [("error",String "Reject"),("kind",String "InvalidKesSignatureOCERT"),("opCertExpectedKESEvolutions",String "19"),("opCertKESCurrentPeriod",String "393"),("opCertKESStartPeriod",String "374")])]),("kind",String "ChainTransitionError")])),("kind",String "HeaderProtocolError")])),("kind",String "ValidationError")])),("slot",Number 5.0990257e7)])),("credentials",String "Cardano")]`

Hmmm
Your KES expired… you will need to rotate them

Type

curl localhost:12798/metrics | grep KES

Cheers,

I have rotated it recently for the first time. And on the gLive also it shows they will expire on 2022-03-23 21:44:51 UTC. What might be the issue. when I run this command cardano-cli text-view decode-cbor --in-file ~/node.cert | grep int | head
I get this output:
01 # int(1)
19 01 76 # int(374)

In the error message it says: “opCertExpectedKESEvolutions”,String “19”
This means that I need to rotate KES keys 19 times ?

should not be 01 … u had this first time… check the node.counter file, what is the "Next certificate issue number: " ?

Try to rotate again and check if now it’s saying 02

before rotating it says 2

Ok, and now it should say 3… try to rotate again and check again the node.cert

yes it has changed to 3 now

should I restart the node now?