Socket Issue (missing) and KES rotation issue

I have 2 issues running in parallel I believe. Please someone help me. @Alexd1985

1.) Hard drive space issues (whereby losing my socket file?)
2.) Started KES rotation, and everything broke now I can’t seem to complete a KES rotation because BP won’t go online due to missing socket or KES being out of sync?

Longer version:
My 128GB Hard drive ran out of space with the size of the DB growing, I purchased a 1TB SSD, installed it and copied over EVERYTHING in the DB folder at the time. (Note, I did NOT see a socket file/folder when I copied it over).

I then restarted the node and everything looked good and the BP started up as a core. I THEN proceeded to delete the old db folder (as the node kept crashing, due to space). and this seemed to work for a little.

However, as soon as I started to the KES rotation process everything stopped working in that either the socket does not exist, or the BP won’t start due to it being incorrect

Issue #1:
blink-bp cardano-node[2257872]: The KES key provided at: “/home/blink_bp/cardano-my-node/kes.skey” does not match the KES key specified in the operational certificate at: “/home/blink_bp/cardano-my-node/node.cert”

Issue #2:
cardano-cli: Network.Socket.connect: <socket: 11>: does not exist (No such file or directory)

For issue 2 u must export the socket path

echo export CARDANO_NODE_SOCKET_PATH="$NODE_HOME/db/socket" >> $HOME/.bashrc
source $HOME/.bashrc

For issue nr 1 u must generate a new certificate, before to do this please check the incremental counter number from node.counter file (u can find the steps on coincashew guide)

PS: the socket file will be automatically created when the node will start… and it will be automatically deleted if the node is offline more than few minutes (I don’t know exactly …)

According to your screenshot, cardano-node creates or tries to create the socket at /db/socket, which is probably not a path, where it can be created. You probably have misconfigured something there, when moving the database to the different location.


So I think this is what I’m trying to communicate, I’m unable to rotate my KES…

I’m following this link:

As you’ll see, at the point I’m trying to get the slotNo and KES period etc, I get a socket error:

Perhaps because the node did not started yet?
Check glive… try to start as a Relay first (delete the paths for pool files from start script)… rotate the KES and add back the path inside start script

If not starting as a Relay perhaps u didn’t change the permisions for new HDD

I definitely haven’t done anything permission-wise for the new HDD… I’m quite a newbie with linux, any advice on what/how I do that?

When trying to use ./ I get this:

If I hit an arrow key while it’s doing this, I see this:

In the start up script (below), which paths should I delete? the cert?

Sorry and thank you so much for helping me :<

Try sudo systemctl status cardano-node

then try cd /media/blink_bp/DB and ls -l

Here we go

and journalctl -e -f -u cardano-node

U also changed the path for socket… it was just a small file so better to keep the socket file/path whwre it was before to move the DB

journalctl -e -f -u cardano-node

Will set the socket back to default now!

ok, and remove those 3 lines from script and try to start again the node as a Relay (remove KES, VRF, CERT lines, save the file and restart the node)

actually u can move all back on ur old location… these are small files… keep only the DB on new HDD

this is how I did it (I moved only the DB to a new HDD)

Updated Socket path to old default:

Restarted node:

./ isn’t working still…

I ran: journalctl -e -f -u cardano-node

Maybe I should do a hard restart of the server?

did u tried to restart the node?

sudo systemctl restart cardano-node

I still see the certificate error… perhaps the start script still have the paths for pool files… can u use the same script as the Relay? But update the paths

cat > $NODE_HOME/ << EOF 
/usr/local/bin/cardano-node run +RTS -N -A16m -qg -qb -RTS --topology \${TOPOLOGY} --database-path \${DB_PATH} --socket-path \${SOCKET_PATH} --host-addr \${HOSTADDR} --port \${PORT} --config \${CONFIG}

Yip, I’m always restarting the node.

I ran the above script with updated paths…

I’m getting a port error when trying to use ./gLiveView, but it looks like something is happening?

Is this looking better to you?

it’s something with the socket path now… check inside the bash file…

cat $HOME/.bashrc and check the export path for socket

also run again sudo systemctl status cardano-node
and check what path is used for socket (use right arrow)

!!! Also check/modify the socket path inside env file

cat $HOME/.bashrc and check the export path for socket

sudo systemctl status cardano-node

could this be a problem?