Error kes-period-info. can´t get KES Period for my new files

Good morning,
I´m having a problem when I try to renew KES. The script followed in Coincashew is not working for me and I have realized that can´t get KES info into my BP.
When i run the commant cardano-cli query kes-period-info --mainnet --op-cert-file $NODE_HOME/node.cert I get the error message saying cardano-cli: Network.Socket.connect: <socket: 11>: does not exist (No such file or directory)
Algo into my GliveView screen I don´t see the KES info correctly.
Can anyone help me to solve this creating new KES in my BP, please?

looks like your keys have expired, you need new ones ASAP.

add to your query kes command the --socket-path PATH_TO_SOCKET to get it working.

to rotate the keys - what guide/tools you are using?

let us kow if you need any help with this.


If u followed coincashew guide when u built the node try this

echo export CARDANO_NODE_SOCKET_PATH="$NODE_HOME/db/socket" >> $HOME/.bashrc
source $HOME/.bashrc

When I used --socket-path it worked. So I have been able to create the new node.cert
Now it´s running and show correct KES Periods
Thanks a lot for quick help

I also used your suggestion, many thanks always !!!