Stake Pool checking balance on Linux

I am creating a stake pool and am having the following error when i try to check the balance of my stake pool account.
failed to make request.
|-> could not connect with node
|-> error trying to connect: Connection refused (os error 111)
|-> Connection refuses (os error 111)
I am able to run a node stats successfully.
PS. It seems to convert my ADDRESS value (which was generated from account) to something different. Not sure why.
Also, in Section 3. Fund stake pool owner account in JCLI - it say that Step 3.2 will change once the Incentivised testnet is launched. Could i be using deprecated steps?

can you share the command you executed?

am seeing the following error now.
jcli rest v0 account get addr1s49jzvmpkm9pkeflh93gn6706vw9ucwzghvah9vzvp36gtklvjf0xjzgcnp -h
failed to make a REST request
|-> node rejected request because of invalid parameters
|-> Client Error: 404 Not Found

Do i need to send funds to the address first?

Yes, probably -I tried your address it failed for me as well, but it worked with mine. At least your address can be fetched in

I have transferred 10 ADA to this address, but it is still failing when i attempt to check the status.
and i think this is also the cause of further issues when i attempt to run the script.

do you have restart jormungandr? i had the same problem.

Yes i did.
I am wondering whether it has something to do with the way i started jormungandr
I started it with the following variables.
jormungandr --genesis-block-hash $(cat genesis-hash.txt) --config “./config.yaml” --secret “./node_secret.yaml” > my_node.log