Staking rewards Ada taken from yoroi wallet

Good day,

Transferred my ada coins from yoroi wallet to another platform to put them on my ledger

Staking rewards were added to my account on yoroi

After I transfered all my ada’s to my ledger I logged back in on yoroi and saw that my staking rewards were transferred to the stake pool. I can’t access them anymore.

What to do?

1 Like

What exactly do you mean with that? If you delegate to a stakepool, your funds stay in your wallet.

1 Like

I restored my wallet on yoroi, gotten my staking rewards from the pool and after I transferred my Ada to a ledger (away from the yoroi wallet) my staking rewards were taken away and not by me

Can you please post a receiving address of your wallet?


Do you mean the address I gotten it from or where it went afterwards?

A address from your own wallet, so i can check and see what happend there.

Can you please copy and paste the address for me? Otherwise i cant use it ^^

To me this sounds like you used a malicious wallet.

You shouldnt receive anything after you restore your wallet.

What exactly did you download? Can you post a screenshot from your Dashboard?

I had a yoroi wallet on my old phone, using the Byron version.

Wanted to open that wallet on my new phone. Downloaded the yoroi app in the AppStore and tried to restore my wallet using the 15 word password.

Only, I gotten the Shelley version instead of Byron. Eventually i could find my Byron wallet on the internet and could transfer it to my ledger. So that worked out.

But I thought that my staking rewards were send to my new Shelley wallet. That was the only explanation I had for getting the new balance there. Only to see it being taken from my Shelley wallet (without me doing anything).

So not sure what or how that happened?

Also, where should the staking rewards usually go? I didn’t see it on my Byron wallet

The staking rewards get “paid” out directly to your reward address which belongs to your wallet.

Because its not possible that you earned any rewards with a byron wallet, as this didnt support the whole delegation/staking mechanism.

1 Like

Thank you! That explains a lot, I do have another wallet, my main one where I do receive my stakings directly indeed. Wasn’t aware Byron didn’t give out any rewards.

But thanks a lot, than I at least don’t have to try and find rewards which aren’t there.

??? If you only had a Byron wallet previously, you never had any staking rewards in the first place.

Staking rewards can only be gained when actively delegating to a stake pool with a Shelley wallet.

What do you mean by “find on the Internet”? Could be legitimate, but could also be scam.

Are you sure that the ADA where transferred to your Ledger? Is the Yoroi wallet you showed screenshots from the one connected to the Ledger?

There are only two transactions on that wallet at all:

The first one can very well be the transfer of your Byron balance. The source address of Ae2tdPwUPEZ8Cadip1Z2iRTK5bhBiyiQicpcvvprTwy5n28L2XsiSrogseU does fit to a Yoroi Byron wallet. But it’s a bit strange that 200 ADA were already rerouted to DdzFFzCqrht7wFFD7yDJSekxVDeFvueziPtedynE2P9wtw16u9VAznR6k4KYCizjsEqLsi3LqhzXBY34VHLZAqStsTquHqo38jTvjS1c there.

But then everything (and not just staking rewards that you didn’t have in the first place) went further to DdzFFzCqrht7wFFD7yDJSekxVDeFvueziPtedynE2P9wtw16u9VAznR6k4KYCizjsEqLsi3LqhzXBY34VHLZAqStsTquHqo38jTvjS1c (together with some other Byron inputs).

If it actually was the Ledger, you would have had to allow that transfer on it.

1 Like

This was in the very beginning when I just started to buy Ada, few years ago I bought a bunch, stored it on a yoroi wallet (didn’t know much about it, and never looked at them until now). My yoroi app wasn’t working anymore, white screen and error after a few seconds.

Wanted to add these coins onto my hard wallet / ledger with the rest of my Ada

A verified website (adalite, something like that) I have used to send my Ada elsewhere.

Because it was a website I tried first 200 and than the rest. Worked out, also gotten it.

But I didn’t know Byron wasn’t giving out rewards.

All clear now

Ah, that Ddz… address is one of the receive addresses of your Ledger connected to Daedalus?

Well, you can use that, but I’d suggest to move that to a Shelley Ledger wallet also. That could be staked and earn rewards and could be used with any other wallet app, not just with Daedalus which gets pretty slow and heavy.

Ah, yeah, is legitimate. What it probably did was putting the 876 something change from your first test send on a Shelley change address for the same seed phrase and then took that out again (together with the rest of your old Yoroi Byron addresses) when you chose to send the rest.

Thank for your help! Will indeed do that and connect it to Shelley. Was a little bit confused. Also read so many posts on how to retrieve your crashed Byron wallet…

But all clear now, cheers mate

Feel free to ask anything here. Can easily get a bit complicated.

When you connect your Ledger to Eternl, Typhon, Lace, … or choose to add a Cardano account to Ledger Live, you should always get a new still empty Shelley wallet, but it should have the same receive address in all of them. You can freely choose which wallet app to use to manage that.

The old Byron Ledger wallet can probably only be controlled by Daedalus (maybe knows what to do when you connect the Ledger there, but I’m really not sure about that).

1 Like