Struggling with topologyUpdater

First time pool operator trying to get the topologyUpdater.sh working.
I have the latest script and env file.
When I run the script it gives me an error:
“mv: cannot stat ‘.tmp’: No such file or directory”

What file is it looking for? Which env variable do i need to tweak?

Which topologyUpdater are you running? Have you tried following one of the major guides? Give it a few hours and it’ll register your relays. Guide: How to build a Cardano Stake Pool - CoinCashew

I am using these scripts:

I’m pretty sure the script should exit nicely even if im not registered. One of my variables is wrong I just need a better error message.

More than likely 1 of the following: 1. The source directory may not exist (OR) 2. The source directory might be empty. Check your CARDANO_NODE_SOCKET_PATH . The updater should ideally be in the same directory as your node

Yup, I’m an idiot and for to remove the comment # mark in the env file…
Script now prints

“Checking for script updates…”

Ill let it run a few hours and see.