TopologyUpdater Error

I run topology updater in my relay and I got this error msg after I run ./

{ “resultcode”: “502”, “datetime”:“2021-02-16 13:55:45”, “clientIp”: “my.relay.ip”, “msg”: “invalid blockNo ” }

Has anyone ever experience this kind of error? Kindly advise.


Try to run the script manually (topology updater) and check again the log
I think it is something related with crontab and topology updater

Hello @Alexd1985, have you been able to run the topologyUpdater script “as is” from cron job?
It did not work for me due to its dependence on environment variables I eventually had to create a script to export the variables and call the Updater. And run this script from cron. It works, but it is more of a workaround than a solution.

I never had this issue… to be honest

That’s strange. Thanks for your answer anyway. And for your tireless work helping others here on the forums.

1 Like

U still using the old guide for relays?

This particular relay was set-up using coincashew guide. So without CNtools, just downloaded the updater and env and created a directory for log. Runs from terminal, but the cron needed the tweak with exporting variables in my case.

But… topology updater should not be connected with env

Let me check another script for u

Here they “curl” both Updater and env.

Are u using this script? For topology updater?

Yes this one after all.

And it’s working?

I think u need to update in env the path manually

Yes I had to update the env then it is downloading topology file from terminal. Not from cron though. I guess I could compare it to the script form my other relays with CNtools.

Interestingly I ran into this yesterday when I had changed permissions of my folder and started running the node under a less privileged user. I got that error when I tried running with the previous user that no longer had permission to read the genesis json to get the network identifier. Your exact problem may be different, but I troubleshooted it by adding a couple echo statement in the script to get the values of variables and the problem became obvious.

Hope this helps,