Error "Invalid BlockNo" (already checked similar posts)


I’m having issues with the topologyUpdater for my second relay. I didn’t have any issues with my first relay by the way. The logs have been showing the following message since I started it:

{ “resultcode”: “502”, “datetime”:“2021-03-31 18:22:16”, “clientIp”: “”, “msg”: “invalid blockNo ” }

I saw in this post Crontab not executing (not working) resultcode”: “502” "invalid blockNo" - #13 by Alexd1985 a similar issue that was solved by checking the ports and the which had the incorrect path. I checked mine and everything looks good, reason why I’m making this post.
location of cardano-cli

Thanks in advance for the help!

maybe the same issue, but no solution yet

yes, I saw that post too. The difference is that for them it was working in the begging it seems. For me it never worked in this relay for some reason.

But… if u are running manually the script (not from crontab)… u are receiving the same message?

I see this message also on one of my relay from time to time… (TBH I didn’t checked the other 2)

yes, but you mentioned that you also have troubles with config.json

When running it manually I get the following message:

It seems to be a permission issue, I tried with sudo I got the same message :confused:

Type ls -l and check the permision of the file

Or even better… can u open the file?

Try nano mainnet-shelley-genesis.json; can u open it?

1 Like

Yes, no issues opening it.

from ls -l mainnet-shelley-genesis.json I get:

-rw-rw-r-- 1 cardano cardano 2486 Mar 16 16:53 mainnet-shelley-genesis.json

I’m thinking if these issues might be related to jq? When I was installing the dependencies I got this error:
and ended up installing it using snap, could that be the root cause?

but maybe you have issues with the file content - could you please verify the syntax with
jsonlint /path/to/mainnet-shelley-genesis.json
if you dont have install it first sudo apt install jsonlint

How are the rest of the files? Same permision rights?

Okay, I think I solved it. The root cause of the issue was that my VM didn’t come with universe repository. Which lead me to install jq with snap and not apt (I’m not experienced enough in Linux to know how this affected everything else) but what I did was install universe repository and then install jq with apt. I also uninstalled the jq from snap just to be safe.

I run manually once more and got the first “nice to meet you” message

And I’m also able to run gLiveView without issues now, which before I was getting error:

Could not parse /home/cardano/cardano-my-node/mainnet-config.json file in JSON format, please double-check the syntax of your config, or simply download it from guild-operators repository!

I hope this helps anybody else struggling with similar errors :slight_smile: and thank you @Alexd1985 and @laplasz for you assistance!


interesting - snap or apt installation does not make difference on app execution… good that you found out what was the issue…

I would have thought the same haha
perhaps it was an issue of where snap installed jq? :thinking: