Stuck on "Resolving Dependencies..." during Cardano Setup

Hi everyone,
I am interested in creating a Cardano token and learning more about how to create a token and what my research shows is I need to setup Cardano first on a server and get the node setup and running similar to like you setup a pool. So I’ve been following pool setup instructions to get Cardano running and I keep getting stuck on the part that says:

Warning: Requested index-state2021-01-10T00:00:00Z is newer than ‘hackage.haskell.org’! Falling back to older state (2021-01-09T22:55:53Z). Resolving dependencies…

I wait for 20+ minutes, try again on a new instance with a different guide and wait for 1 hour, it just gets stuck there. I go into htop and it shows it starts but then goes idle at 0. The whole time it’s stuck on that resolving dependencies screen and never changes. I am on AWS ubuntu with 2cpu and 8gb ram.

I have followed multiple written and video guides over the last few days and I feel like many might be outdated because if you try with them now they don’t work. Literally copying and following along.

Does anyone have a guide that they’ve tried recently that worked for you that you can direct me to? I almost feel like creating video capture going through it to show how these guides aren’t working. We need better guides, better videos, I wish more users would create them. :slight_smile:

Thanks.

If you just want to have a running node without the compile and all the other stuff, you could do …

$ docker run --detach \
    --name=relay \
    -p 3001:3001 \
    -e CARDANO_UPDATE_TOPOLOGY=true \
    -v node-data:/opt/cardano/data \
    nessusio/cardano-node run    

Details about this are here.

Hey Tom,
It seems that my issue was AWS for some reason. I switched to Google Cloud and ran the same commands and the install is progressing further along now and is not stuck. I will progress along and see how it goes.

I would like to create a Cardano token, are there any resources on how to do this that you’d recommend as far as guides or video guides?

That message can safely be ignored when the expected date and the actual date are so close together.

I’m having a similar issue. Running $ cabal configure --with-compiler=ghc-8.10.2
gets stuck at resolving dependencies

‘cabal.project.local’ file already exists. Now overwriting it.
Warning: Requested index-state2021-01-10T00:00:00Z is newer than
hackage.haskell.org’! Falling back to older state (2021-01-09T22:55:53Z).
Resolving dependencies…

What can we do to resolve this?

What do you mean by:

gets stuck at resolving dependencies

I have seen that take up to 10 minutes, but it either succeeds or fails with an error message.

I’ve waited for about an hour and nothing showed up, but with fustration I spammed the enter key and then bam, the dependencies all showed up… I think it was a console issue just not displaying the output automatically.

On AWS for me it hangs on resolving dependencies. I just tried it again and it’s been stuck on it for over an hour. I give up on AWS working for me, it just doesn’t want to work. It just sits on resolving dependencies… for over an hour+ with AWS.

I switched to Google cloud and ran the same commands and was able to get the node setup using a guide found here:

Had the same problem on AWS… stuck at “Resolving dependencies…” for a long time (approximately 30+ minutes).

Killed the first attempt and started over with:

cabal clean
cabal update
cabal build all

Seemed stuck in the same place, but eventually started progress (after approximately 10+ minutes).