Testnet faucet doesn't work?

Hi!
I tried to request some ADA from the faucet (Request funds to the faucet - Stake pool course) but I haven’t received any funds on my account. https://cardano-explorer.cardano-testnet.iohkdev.io/ shows only “SORRY, WE COULD NOT FIND ANY RESULTS MATCHING:” and when I run cardano-cli shelley query utxo --address $(cat payment2.addr) --testnet-magic 1097911063 I get as a result empty account:

What I should do? I tried to find an answer on the internet but I didn’t found anything.
Thanks.

Can u try the commands without shelley subcommand?

I get an error:
Invalid argument `query’
Usage: cardano-cli (Byron specific commands | Shelley specific commands | Miscellaneous commands)

But did u got the success message when u tried to request ADA for test? Can u try again?

I don’t have any success message just this:

No, when u asked in application for ADA; I saw in tutorial video that u should receive a successful message

Oh, ok - I received success message and I got a link to check transaction but there was an only message: SORRY, WE COULD NOT FIND ANY RESULTS MATCHING.

Sorry It seems, as u said, no ADA received… strange; I don’t know what could be the issue

1 Like

You need to add --allega-era to your command, as testnet is in Allegra now.

Sounds like you also need to update your cardano-node and cardano-cli to be 1.24.2 or higher. The mentioned command syntax works only post 1.24.2, and nodes prior will not be able to sync further.

2 Likes

Thank you very much! I have one more question: if testnet is in Allegra which of config files should I use? From Allegra or from testnet? Cardano Configurations

Thanks

The page you referred to are name of the networks (agree-ably the nomen clature of some of them conflicts with the actual era), but since you’re using testnet network, you can stick to using config corresponding to testnet row.

1 Like

Thanks now everything is clear and working!

1 Like