Testnet Stake POOL course

Hi all!

I am not a programmer more over an investor who tried a lot of things even mining 4-5 years before.
Those kind of people the good average not using linux as not visual, even apple are popular just in tiny segment. Most people having windows machine as it simple do not need any clue to use them.

I got Windows system and went trough on the stake pool lessions step by step what is really IDIOT PROOF :smile: .
Used Putty what is working well looks like.

Nearly finished the 2nd chapter just the simple ada transfer left back and recognise my node stopped somehow. Used AWS server exactly the same setup, only server IP was public as I get a tiny help from a friend just he never has time properly.
So when stopped the node run of course you try to restart is but it never happened again as this message comes up:

   __|  __|_  )
   _|  (     /   Amazon Linux 2 AMI
  ___|\___|___|

https://aws.amazon.com/amazon-linux-2/
[ec2-user@ip-172-31-3-169 ~]$ cardano-node run \

–topology testnet-topology.json
–database-path db
–socket-path db/node.socket
–host-addr 18.133.171.97
–port 3001
–config testnet-config.json
InvalidYaml (Just (YamlException “Yaml file not found: testnet-config.json”))

cardano-node: YAML exception:
Yaml file not found: testnet-config.json[ec2-user@ip-172-31-3-169 ~] clear [ec2-user@ip-172-31-3-169 ~] cd PRODUCTION
[ec2-user@ip-172-31-3-169 PRODUCTION] [ec2-user@ip-172-31-3-169 PRODUCTION] cardano-node run \

–topology testnet-topology.json
–database-path db
–socket-path db/node.socket
–host-addr 18.133.171.97
–port 3001
–config testnet-config.json
[cardano.#ekgview.realizeFrom:Error:5] [2020-08-23 06:54:56.30 UTC] EKGView back end disabled due to initialisation error: EKGServerStartupError “Network.Socket. bind: resource busy (Address already in use)”
[ip-172-3:cardano.node.release:Notice:5] [2020-08-23 06:54:56.34 UTC] CardanoPro tocol
[ip-172-3:cardano.node.networkMagic:Notice:5] [2020-08-23 06:54:56.34 UTC] Netwo rkMagic 1097911063
[ip-172-3:cardano.node.version:Notice:5] [2020-08-23 06:54:56.34 UTC] 1.19.0
[ip-172-3:cardano.node.commit:Notice:5] [2020-08-23 06:54:56.34 UTC] 4814003f143 40d5a1fc02f3ac15437387a7ada9f
DbLocked “/home/ec2-user/PRODUCTION/db/lock”

cardano-node: The db is used by another process. File "/home/ec2-user/PRODUCTION [ec2-user@ip-172-31-3-169 PRODUCTION]$

The only changes from SP course I used PRODUCTION instead of relay.

THIS ERROR COMES UP:

[cardano.#ekgview.realizeFrom:Error:5] [2020-08-23 06:54:56.30 UTC] EKGView back end disabled due to initialisation error: EKGServerStartupError “Network.Socket. bind: resource busy (Address already in use)”

Some one knows what happened?


Also other thing what did not worked well for me. Carlos in the lession start to talk about that to do some tricks to show up double screen and run the node in one and you can monitor visual the running pool instead of prompt lines. In second tab you can continue your programming.
In windows 64bit system using Putty to connect to AWS server that does not worked. So i have to run my pool original watching prompt lines.

  • nano shelley_testnet-config.json

This line does not worked as it opened up the setup file but dont show up nothing on the screen. So I did not seen the options to turn on or switch off anything.

The node in double screen using tmux was running for me about 5-8 hours but time to time i recognise the running node refreshing slower and before cut off its was 1 hour behind of the real time.

Any Idea whats going on by me and how can I fix this instead of start everything from the beginning?
Many thanks for any help!!!

Hello Attila,

Your first issue is a misconfiguration with file paths. It seems you are starting the node from within the cardan-node directory. Error messages are very useful - the error “Yaml file not found: testnet-config.json” implies the specified file does not exist. You have to specify the full or relative path to this file on the system. Once that error is resolved, I suspect you will see another error relevant to testnet-topology.json. In short, I suggest using the full path names to the all the file references, which will allow you to run cardano-node from any directory.

Your second error indicates some portion of the previous instance is still running - “The db is used by another process.” You should kill that process and try again - killall-cardano node may help, but is not considered a graceful way to shut the node down.

Again, your third issue - “nano shelley_testnet-config.json” - should either be performed in the directory that contains your config file, or using the full file path to the config file - and also use the exact same name as your config file.

If you plan to migrate to a production stake pool on mainnet, I strongly recommend brushing up on Linux and spending time practicing generating your keys and building and singing transactions an offline environment. The guides do not provide much help in regards to securing your environment or private keys. There is a lot of useful information in this forum on those topics though.

Your Friend, FROG

2 Likes

The frog, the myth, the legend…

1 Like