Tried a clean install with CNTools but won't install ghcup

I was wanting to clean up some old install issues, so i just wanted to do a clean OS and Node install using CNTools. But when running, keep getting this message:

“Installing missing prerequisite packages, if any…
Install ghcup (The Haskell Toolchain installer) …
curl: (28) Connection timed out after 60001 milliseconds”

Going on 24 hours now.
Worked fine the other day when i rebuilt one of my other relays.

What OS run on server? Same as relay?


Yes, same. Ubuntu Server 20.04.4

install ghc… I think u can install it manually

so, the script is trying to access the link but it looks is down

echo "Install ghcup (The Haskell Toolchain installer) .."
    curl -s -m ${CURL_TIMEOUT} --proto '=https' --tlsv1.2 -sSf | bash has a larger problem for quite some time (like 24 hours) now:

They seem to be working on it, but at the moment, you simply cannot install ghcup.

1 Like

U can try to download the folder from ur relay
should be located here

cd ${HOME}/.ghcup/

but u will need to esit the env file with the local node user and probably more things to do so better to wait

1 Like

Oof…thanks for the help and update, folks. Guess I’ll play the waiting game. :metal::orange_heart:

I see the site is available now… so go to work :))

Cheers :beers:

1 Like