Trobleshooting my BP and Relays


I have just added another Relay to my network and everything seems to be running fine. But I don’t know why my Core node is 2:1 Out/IN peers. My ports are open to the nodes and my BP node has the incoming connection set to my 2 Relays.

I can telnet to my newly added Relay from my BP but when I telnet from my New Relay to my BP there is no connection.

Thanks :pray:

Did you add your bp’s IP address to the relay’s topology file?

1 Like


Yeah its in there alright.

Is the firewall of the BP accepting the incoming port of the relay?

Yes it is, I have the cloud FW set to my Relay port and IP

Does the cloud FW need time to be in effect? do you have to restart anything? if your bp has the ports/ips open than you should be able to ping from relay to bp.

I’v restarted a couple of times but still the same. I’v checked all ports and I don’t know why its not able to connect. On its says Relay node is missing in topology.json

You need topology updater script for that. if you used cntools method it will be there in a few hours.

1 Like

try this to see if your bp’s port is open or not:

Open Port Check Tool - Test Port Forwarding on Your Router (

1 Like

Thanks for this.

Says the port is closed.

1 Like

Maybe the order of the rules in the firewall is an issue? my fw sets the rules as they come up in the list from top to bottom. And try to remove the rule and check again to see if that solved it.

Will try to set the rules again to see if resets. Thanks again! :+1:

1 Like