Trying to send pool deposit 500 ADA but I have 2 TxHash


I’m trying to make deposit 500 ADA but I was transfer 2 amount to my the address which total balance more than 500 ADA.

I was tried to use 2 tx-in like this
cardano-cli transaction build-raw
–tx-in xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx757#9
–tx-in xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx787#0
–tx-out $(cat payment.addr)+7641322
–invalid-hereafter 21042920
–fee 186225
–out-file tx.draft
–certificate-file pool-registration.cert
–certificate-file delegation.cert

Then I submit the transaction, it return error:

…(ValueNotConservedUTxO (DeltaCoin 470000000) (DeltaCoin 507827547))))

How would I fix this?

Thanks for the help.

When I ran into this issue, it was a combination of two things:

  1. Fee calculation was incorrect (there was a separate error message about that)
  2. Because of that, output (change) != inputs - fee - 500 ADA

The minimum fee calculation didn’t always return the right result for me, but attempting to submit the transaction would tell me what the actual fee was supposed to be. Once I corrected the math, this issue was resolved.

I had no issues submitting transactions with both 2 and 3 inputs using the format you’re using. I found that the fee calculation when I had multiple inputs didn’t always line up with what the minimum fee calculation said it should be (not sure why yet, still figuring that one out).

1 Like

This process successfully done:)

Thank you very much