Unable to monitor node with RTview


I have a single node running on my local computer. I am trying to get RTview up and running with no success.

The node appears to be running ok:

cardano@tom-ThinkPad-X220:~/cardano-node$ cardano-cli query tip --mainnet
"blockNo": 2637139,
"headerHash": "e0ba3286ec9e95806c32886c7065205fe941a421ed004f81337e635393f03a56",
"slotNo": 2638653


Here is the config file which hopefully I have modified correctly, according to guidance from RTview:

  "ApplicationName": "cardano-sl",
  "ApplicationVersion": 1,
  "ByronGenesisFile": "mainnet-byron-genesis.json",
  "ByronGenesisHash": "5f20df933584822601f9e3f8c024eb5eb252fe8cefb24d1317dc3d432e940ebb",
  "LastKnownBlockVersion-Alt": 0,
  "LastKnownBlockVersion-Major": 2,
  "LastKnownBlockVersion-Minor": 0,
  "MaxKnownMajorProtocolVersion": 2,
  "Protocol": "Cardano",
  "RequiresNetworkMagic": "RequiresNoMagic",
  "ShelleyGenesisFile": "mainnet-shelley-genesis.json",
  "ShelleyGenesisHash": "1a3be38bcbb7911969283716ad7aa550250226b76a61fc51cc9a9a35d9276d81",
  "TraceBlockFetchClient": false,
  "TraceBlockFetchDecisions": false,
  "TraceBlockFetchProtocol": false,
  "TraceBlockFetchProtocolSerialised": false,
  "TraceBlockFetchServer": false,
  "TraceChainDb": true,
  "TraceChainSyncBlockServer": false,
  "TraceChainSyncClient": false,
  "TraceChainSyncHeaderServer": false,
  "TraceChainSyncProtocol": false,
  "TraceDNSResolver": true,
  "TraceDNSSubscription": true,
  "TraceErrorPolicy": true,
  "TraceForge": true,
  "TraceHandshake": false,
  "TraceIpSubscription": true,
  "TraceLocalChainSyncProtocol": false,
  "TraceLocalErrorPolicy": true,
  "TraceLocalHandshake": false,
  "TraceLocalTxSubmissionProtocol": false,
  "TraceLocalTxSubmissionServer": false,
  "TraceMempool": true,
  "TraceMux": false,
  "TraceTxInbound": false,
  "TraceTxOutbound": false,
  "TraceTxSubmissionProtocol": false,
  "TracingVerbosity": "NormalVerbosity",
  "TurnOnLogMetrics": true,
  "TurnOnLogging": true,
  "defaultBackends": [
  "defaultScribes": [
  "hasEKG": 12788,
  "hasPrometheus": [
  "minSeverity": "Info",
  "options": {
    "mapBackends": {
      "cardano.node-metrics": [
       "cardano.node.Forge.metrics": [

      "cardano.node.metrics": [
    "mapSubtrace": {
      "cardano.node.metrics": {
        "subtrace": "Neutral"
  "rotation": {
    "rpKeepFilesNum": 10,
    "rpLogLimitBytes": 5000000,
    "rpMaxAgeHours": 24
  "setupBackends": [
  "setupScribes": [
      "scFormat": "ScText",
      "scKind": "StdoutSK",
      "scName": "stdout",
      "scRotation": null
  "traceForwardTo": {
     "tag": "RemoteSocket",
     "contents": [

Here are ports with node and RTview running:

Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0  *               LISTEN      -               
tcp        0      0 *               LISTEN      -               
tcp        0      0  *               LISTEN      9720/cardano-rt-vie
tcp        0      0  *               LISTEN      9720/cardano-rt-vie
tcp        0      0*               LISTEN      9607/cardano-node
tcp        0      0 *               LISTEN      -               
tcp        0      0*               LISTEN      9607/cardano-node
tcp        0      0*               LISTEN      -               
tcp        0      0*               LISTEN      -               
tcp        0      0*               LISTEN      9607/cardano-node
tcp6       0      0 ::1:631                 :::*                    LISTEN      -               
tcp6       0      0 :::17500                :::*                    LISTEN      -               

Here is RTview webpage, any idea why data is not getting to the webpage?

Screenshot from 2021-02-04 10-46-27

1 Like


if you keep the default port 8024 , the web-page will be available on

And at the end… again they specified:

After you pressed Enter , RTView will be launched, and you can open (if you chose default web-port) and see the web-page.

Then, why are u using to access the node? :smiling_imp:

Hi Alex,

Yeah, sorry, I should have said I tried after having no luck on

Screenshot from 2021-02-04 17-54-04

I’ll go through the config file again to make sure there are no errors there. Any other ideas?


ur server is running on the same machine , I mean on your desktop? or it has a public IP address… hosted separately?

try with public_IP:8024

also u can check this post

Yes server was running on same machine, my laptop. Haven’t had time to look at again so still no solution, will get back to it eventually. Thanks for your help

Hi Tom I am having the same issue. I can’t properly install RTView…the instructions are pretty unclear on Github…I am not sure what to do from here, but at least my node is running!

Yeah, I still have had no luck with RTView. I reinstalled the node using this guide:


and then ran the gLiveView script located in

relay@vmi524346:/opt/cardano/cnode/scripts$ ls
balance.sh          cnode.sh         cntools.sh            env            logMonitor.sh      setup_mon.sh    system-info.sh
cabal-build-all.sh  cntools.config   createAddr.sh         gLiveView.sh   rotatePoolKeys.sh  sLiveView.sh    topologyUpdater.sh
cncli.sh            cntools.library  deploy-as-systemd.sh  itnRewards.sh  sendADA.sh         stack-build.sh

to give some basic monitoring:

Screenshot from 2021-02-13 17-35-31

I had the same issue and solved it by adding “TraceForwarderBK” to

“defaultBackends”: [

in the node’s config file.
However, I didn’T find any documentation about it :frowning:


This worked for me as well

When configuring RTView on run, the instructions say to Find options → mapBackends in config.json for the node and redirect required metrics to “TraceForwarderBK”

I added “KatipBK” to the node config and that seems to be working. Is “TraceForwarderBK” incorrect?