Upgrading Producer to 1.35.3, getting errors when building the node


We are currently trying to upgrade our Stake Pool to 1.35.3 from 1.32.1, we have tried upgrading multiple times but the upgrades always fails with the below errors (we currently use CNTOOLS to manage and run our stake pool):

When we hit the last cabal build all command for the upgrade we get this error, mainly saying “Cabal: Could not resolve dependencies” then a bunch of errors after that here:
Cabal: Could not Resolve dependencies

When I try to run gLiveView.sh it shows this error:

It also seems my node can’t even start successfully now and I don’t know why, here is what I see when I run the status cnode command:

And this is what I see when I check the journal: journalctl -e -f -u cnode

I’m not sure what to do here as it seems it’s really “cross-eyed” right now, any help is really appreciated!! :slight_smile:

one sure fire way to resolve this is the rebuild the node with a fresh OS install.

But here is something else you can try.

  1. rm -r ~/.cabal/packages
  2. cd ~/tmp
  3. rm software_upgrade.sh (if needed)
  4. wget https://raw.githubusercontent.com/Alexd1985/node_software_upgrade_script/main/software_upgrade.sh
  5. sudo chmod +x software_upgrade.sh
  6. ./software_upgrade.sh

I am currently trying the commands you pasted, ill let you know if it works!

How can i rebuild the node with a fresh OS without losing my stake pool registration or messing up my current stake pool? Im not sure what files i would need or what I’d need to do.

Thank you for your help and insight!

I ran those commands and unfortunately got the same errors when building the node:
after running latest commands

what versions of ghc and cabal?

cabal --version
ghc --version

You should have already made a backup of all of your important keys. This can be done in the cntools.sh console. then you will need to transfer that file to an offline storage via scp and or thumb drive.

Your commands above helped me a lot, when it ran the prereqs.sh it showed me a couple warnings how my ghc and cabal were “shadowed” and I needed to remove them so that the upgrade could take place, so I removed them and went through the steps and successfully upgraded to 1.35.5!!

Thanks for the quick assistance/help!!


Well done sir