0 Total TX, Missed / Ghosted blocks on my Preview BP node

I’m trying to learn the ropes on operating a stake pool so I setup my own Preview BP node on my Windows 10 PC using VirtualBox. I followed the guide at Guild Operators website and all is looking well synced and running smoothly except that when it’s my schedule to mint a block I always get “Missed” or “Ghosted”. I think it’s already my 3rd epoch with leader schedules but could not get the node to mint a block. I understand that height battles/block propagation issue happens and I’m trying understand where or why this is happening to my preview node. I also noticed that the “Total Tx” and “Pending Tx” are always at 0 even when the node is up for many hours. I though that might be related to why the node always missed but im not sure.


I’m using these unchanged topology.json and config.json files found at:

I did not setup any relay so I’m just using preview-node.world.dev.cardano.org as you can see from the topology file above.

Here’s the opcert file:

✓ Operational certificate's KES period is within the correct KES period interval
✗ No blocks minted so far with the operational certificate at: /opt/cardano/cnode/priv/pool/testpool/op.cert
  On disk operational certificate counter: 0
    "qKesCurrentKesPeriod": 47,
    "qKesEndKesInterval": 163,
    "qKesKesKeyExpiry": null,
    "qKesMaxKESEvolutions": 120,
    "qKesNodeStateOperationalCertificateNumber": null,
    "qKesOnDiskOperationalCertificateNumber": 0,
    "qKesRemainingSlotsInKesPeriod": 10021081,
    "qKesSlotsPerKesPeriod": 86400,
    "qKesStartKesInterval": 43

I’m running out of ideas so any help is very much appreciated.

Peer analysis:

You’re not getting incoming peers. Firewall? Have you got your p2p config right? i.e. it matches the port and IP you’re listening on?

Hi @ jeremyisme,

ufw firewall is not active or configured yet. How do I configure my P2P port?

Add your node IP and address into the local roots part of the topology.json


"localRoots": {
 "accessPoints": [
 "address": "XX.XX.XX.XX",
            "port": 6000
1 Like

Thanks! I just updated the topology file and now I’m seeing 2 Incoming but Total Tx still at 0.


Do you know what’s the "advertise": false under the topology file for?

Good. It’ll take a while for your node to propogate through the network. Wait 12 hrs or so and hopefully you’ll have more incoming and then the txs should start increasing.

check if u have TraceMempool set to false inside configuration file, if yes set it to true and restart the node; now u shoukd see tx processed

It’s already set to True as the default setting when i downloaded the file.

Still at 0 for Total Tx.

Who is 1 incoming peer? Can u check with P inside glive?


whats ur IP? Let me add to my topology file

My node’s ip is …

oops sorry should have pm’d you.

Its ok… I added ur IP inside topology file, wait for my node to start…

One block created but let’s hope it get’s confirmed. It usually just gets “Ghosted” or “Missed”.

Check now tx processed
Do u see my node now? It has .250 at the end

Total Tx 0 still. How to check your node is in mine?

Press P on glive