Air-gapped machine troubles - version ‘GLIBC_2.33’ not found

It says it’s currently on version 9.3.0.

and what is the version of libc on your hot machine where you copied the cardano-cli from?

That one is currently on version 10.2.1

please confirm this versions with ldd --version

Relaynode version:
Screenshot from 2021-06-21 12-49-24

Air-gapped machine version:
Screenshot from 2021-06-21 06-48-57

that is it!

As you can see the machine where the command was compiled has the version 2.33
and the air gapped only 2.31

what is the distribution and versions on the two machine?
Also I think if you would download the cardano-cli it should not be a problem…

I downloaded the cardano-cli like you said and I think there has been some progress now.

I tried the command with my Owen user but I had no permission so I tried it again but with the root user and I had no error this time, which is good. But aren’t I supposed to see some keys in the “cold-keys” file now? Because there don’t seem to be any.

everything should work without root.
In the current case the keys generated under /root - to verify it just list the content of that folder:
ls -l /root

You are correct, the files are indeed generated there. I will close this issue and open a new one for the permission problem.

Thank you so much for the help! :slight_smile:

Cheers,

Owen

dont need:
just dont use /root path when using the other user, so back to the original command:

cardano-cli node key-gen \
--cold-verification-key-file node.vkey \
--cold-signing-key-file node.skey \
--operational-certificate-issue-counter node.counter
1 Like

Oh yes you’re right! I thought I used my original command that I pasted in here but I used the edited version.

Hi guys, I am facing the same issue and I am not sure to understand how to solve this.
Correct me if I am wrong, but there is no need to use the same cardano-cli that is on my block producer server?
So basically, if I am correct, I can retrieve the cardano-cli file from the following link: GitHub - input-output-hk/cardano-node: The core component that is used to participate in a Cardano decentralised blockchain.

If yes, could you please tell me where on the said website I need to click to download the cardano-cli file to be copied to my offline machine (there are so many links…)?
Sorry if this question sounds stupid but I am a newbie :slight_smile:

Thank you in advance and have a great day!

EDIT: I managed to solve the issue by myself.
If this can help anyone:

  1. Download the Linux package: Hydra - Build 6988090 of job Cardano:cardano-node:cardano-node-linux

  2. Copy the TAR.GZ file to your offline machine

  3. Open the TAR.GZ file on your offline machine and extract the cardano-cli (in this case let’s say to the the Desktop)

  4. Open the terminal and enter the following commands
    cd Desktop
    sudo cp cardano-cli /usr/local/bin

  5. the following commands should now work:

mkdir $HOME/cold-keys
pushd $HOME/cold-keys

cardano-cli node key-gen
–cold-verification-key-file node.vkey
–cold-signing-key-file node.skey
–operational-certificate-issue-counter node.counter