BP + 2 Relay on since 1 week but no block produced on Testnet

Hello everyone,

I set up on testnet a BP and 2 relay’s following the coincashew tutorial and Alexd1985 BP tips topic, everything looks properly setup:

  • topologuUpdater registered and connected for each Relay

  • BP connected in and out to both relay only

here what i have from gliveView for each: as you can see i’m still with 0 block produced since a week

I couldn’t find my node on poolvet but on daedalus testnet i got it and i even delegate ada on my pool.

there is a period to wait before producting block (like 2 epoch) or my registration has an issue?


1 Like

You have to wait 1-2 epochs (can’t recall the exact number) but in order to process a block your pool needs some big delegation. Currently, it says 0ADA for the live stake but that is because the pool was just registered.

Try the SPO Telegram channel and ask if someone can help you with a delegation.

Regarding delegation registration. In case you just registered a staking key you will need to wait 4 epochs until you receive staking rewards… of course the pool needs to produce blocks to get the awards.

Hi @julian2 ! How long it took before it appeared in Daedalus? I have my pool running in testnet for almost a week, but still can’t find it in Daedalus.

@os11k please check the metadata hash. See commands below.

If the hashes are equal check if you can find the pool on:

In case you can find the pool with those tools but not with Daedalus, check if the description is longer than allowed.

Hi @mcrio ! Seems you are correct, I have wrong metadata hash. Seems gist removed new line at the bottom of file, but I had it in my file. And I calculated hash based on file, not what is uploaded to github gist. It would be nice probably to update coincashew manual so it will calculate hash not from file, but rather from URL as you sent.

So what is next? How I can easily fix this without starting everything from scratch?

You need to resubmit the pool certificate:

Usually people update their metadata files on servers (hosting platforms) they have control of, so for those cases it would be a matter of reuploading the file.

1 Like

I’m using github gist, but seems I can’t add new line at the bottom. :frowning:

Correct, Gist will remove it automatically. You need to resubmit the pool certificate. It’s easy, and you will need to pay just for the transaction fee. It’s good to practice that as that is something

I fixed it, thank you so much!!!


@os11k Cool, glad it worked :+1:

(if you don’t mind please mark the post that solved it as “solution” so others can find the answer more easily)

I’m not OP for this post, so I can’t do this, I suppose. I asked similar question in separate thread, there marked as solved. :wink: Cheers!

hehe you’re right, I see now :smiley: :beers: