I created stake pool in testnet, but I still can't see it with testnet Daedalus

Hi! I created test pool in testnet, ticker - 999, it is already 2 days passed, but I still can’t find it in Daedalus testnet. Seems pool operates ok, but based on grafana it seems it didn’t produced any blocks yet. Is it normal?

I monitor pool performance with:
(cardano_node_metrics_Forge_forged_int{alias=“test-producer”} / cardano_node_metrics_Forge_node_is_leader_int{alias=“test-producer”} * 100)

And it still shows as N/A, what suggests that no blocks produced.

Additionally I run official docker images, for nodes and those images lucks gLiveView & CNCLI. In grafana I see TX processed on both relays and producer.

I tried to add gLiveView & CNCLI to my docker image, but without success. Those images even don’t have apt command. I has some mixed results running gLiveView from host, but screen is not displayed correctly.

Looks like I will miss those tools. Are those tools mandatory for lunching pool in production? Or there are enough data in Grafana?

It was due incorrect metadata-hash. I calculated hash based on my file locally what had new line at the bottom of file, I uploaded same file to github gist, but seems github gist removes new line at the bottom. That why there were inconsistency.

I fixed it by resubmitting certificate, thx to @mcrio

Just for the archive, see here how to compare the hashes:

1 Like