Can not copy newly built binaries to the appropriate directory

i can’t copy the newly built binaries to the appropriate directory.
The last step from here:

How can i find the version of the cardano cli and the cardano node?
if i put in this code
cp -p dist-newstyle/build/x86_64-linux/ghc-8.10.2/cardano-cli-<NEW VERSION>/x/cardano-cli/build/cardano-cli/cardano-cli ~/.local/bin/
the tag number “1.25.1” it says
“cp: call of stat for dist-newstyle/build/x86_64-linux/ghc-8.10.2/cardano-cli-1.25.1/x/cardano-cli/build/cardano-cli/cardano-cli ~/.local/bin/ not possible: File or directory not found”

Best regards


did u installed 1.25.1 or 1.29.0? 1.25.1 it’s an old version

i’m not sure. Can i update it?
Or how can i look which version i have installed?

if you copied from guide the commands:

git fetch --all --tags
git tag
git checkout tags/1.25.1

then you installed 1.25.1

ok. i redid this step with 1.29.1.
Do i have 1.29.1 installed?

1.29.0 is the latest version released

i tried that with 1.29.0 but im still getting the same error

Ok, do u want to install the node for testnet or for mainnet?

1 Like