Cannot install Daedalus 3.3.2 on Ubuntu 18.04 LTS

Following the instruction here, I can’t install daedalus-3.3.2-mainnet-16919.bin on a Ubuntu 18.04 LTS laptop successfully. The error message is below:

./nix/store/apzfc51a2aki7xdyzifldp1nm4w8a1am-nix-user-chroot-2c52b5f/bin/nix-user-chroot: error while loading shared libraries: cannot open shared object file: No such file or directory

Following is my /etc/nix/nix.conf :

substituters =
trusted-substituters =
trusted-public-keys =
max-jobs = 2 # run at most two builds at once
cores = 0 # the builder will use all available CPU cores
extra-sandbox-paths = /System/Library/Frameworks
build-users-group =

The laptop has 4 CPUs, 16GB memory, 66GB available SSD disk space.


I would suggest to first go through on these answers - Linux error while loading shared libraries: cannot open shared object file: No such file or directory - Stack Overflow
for exmaple this one:
“This might happen if you have recently installed a shared library and didn’t run ldconfig(8) afterwards. Do ‘ldconfig’, there’s no harm in it. - or sudo ldconfig”


Thanks for your reply.

I have tried to set the LD_LIBRARY_PATH env variable:

LD_LIBRARY_PATH=/lib/x86_64-linux-gnu ./daedalus-3.3.2-mainnet-16919.bin

then have another error:

Segmentation fault


yeah I can find libpthread as well on my Ubuntu:


but I think this is a default folder for shared libraries so LD_LIBRARY_PATH not needed to point there.
Actually I just installed Daedalus 3.3.1 on fresh Ubuntu 20.04 yesterday without errors…
but have not tried 3.3.2 yet…
what is the printout before Segmentation fault?

The only output is “Segmentation fault”, no other logs.

By the way, where can I find old versions of Daedalus, I didn’t find the link to previous versions on the website?

yes - somehow only the latest version is available… but I dont think It will solve your issue…
there is a flag --extract can you try it?

daedalus-3.3.2-mainnet-16919.bin --extract

Yes, I have tried the extract method as per here, the error is the same.

However, I have another laptop (Ubuntu 16.04), on which I install latest Daedalus successfully.

Now Daedalus is syncing data.

ok - probably not generic issue but worth to report it on github:

yeah, alreay reported an issue on GitHub.

Now my major problem is the network speed of syncing data. I’m from China, and the syncing speed is EXTREMELY slow. I’m wondering if I can use Daedalus behind a SOCKS5 proxy.

:slight_smile: that is my problem also - started yesterday - still syncing - I guess 10 hours needed from 0% to 100%
and need 8GB already - so coinsider using YOROI… same functionalities without the need of local sync…

I think my situation is even worse because of the Great Fire Wall of China. I start Daedalus from command line using this command proxychains /home/leslie/.local/bin/daedalus-mainnet, behind a SOCKS5 proxy, but It’s still 0% complete… :disappointed:

Yeah, I downloaded Yoroi on my cellphone today. Actually I’m recovering a Daedalus Byron wallet which I installed on a Windows 7 laptop 3 years ago. Didn’t open that wallet for 3 years.

I just found I can’t recover a Daedalus Byron wallet directly to Yoroi. That’s why I need to install Daedalus again.

After transferring my assets to Yoroi, I will say farewell to Daedalus.

1 Like