Can't Establish Connection between Yoroi and Ledger Nano X

Hello. I am having a problem claiming my staking rewards in Yoroi (iOS) which is linked to my Ledger Nano X. My bluetooth is on, the ledger is on, the cardano app on ledger is open but, it get stuck at “Please follow steps shown on your ledger device” and nothing gets passed on to my ledger after that.

It may be also helpful to add that it returns the same problem when trying to verify my wallet address in yoroi to my ledger. It is displaying connection error.

I will add informations below and troubleshooting that I already tried just to filter suggestions on possible fixes.

Yoroi Version (iOS) : 4.4.2
Ledger Nano X : Firmware 2.0
Cardano app on ledger : v2.4.1

Troubleshooting i tried:
•Restarted Ledger
•Restarted iPhone
•Forget bluetooth connection then re-paired
•Made sure Ledger Live is not connected to my Ledger
•Re installed Yoroi
•Re installed Cardano on ledger

All of the above did not work and returned the same connection issue.

I’m attaching screenshots of the error on both claiming rewards and verifying wallet address.

Thanks guys, Cheers!!


Did you already try to connect your Ledger via computer on Yoroi? There might be an issue with the mobile version.

I will try doing this tomorrow when I have access to my laptop.

I think I started to experience this issue 4 months ago since I also needed to delegate to pool using my laptop because of the same connection problems.

Thank you, sir.

1 Like