Having issues using Yorio on iPhone with Ledger Nano X. help much appreciated

Hello all,

I’m using a Nano X with Ledger app and Yoroi app. Firmware is updated. I can sent coins from my Ledger app anywhere, after giving in the key with the Ledger. so far, so good.

However, I created Shelley-wallets on the Yoroi app. Cab receive ADA. But cannot sent it out and/or stake. I can choose a staking center, or an address for sending, but as soon as I hit Continue nothing happens. Bluetooth connection seems to be working but Yorio and Legder are not communicating. Again, it works fine on the ledger app, just not with the Yorio app (and thus ADA).

Is there a genius out here who could please help me out? Im kinda stuck

Kind regards!

could be an issue with the Yoroi (you can contact yoroi team via the app)/ Do you have the possibility to try on a PC/laptop?

Hi Alex,

It must indeed be something with Yoroi or between Yoroi and Ledger, for the Ledger app runs smoothly. Don’t think I can try on a laptop? Yoroi runs only on iPhone?

nope, you can download (from official source) the chrome extension for yoroi and pair the ledger… should work to perform transactions/delegate.
Or if you don’t want to install anything then just open adalite.io (on laptop) and connect the ledger (it’s 100% safe)

hm, doesn’t seem to work Alex. I run on IOS (MacBook Pro) and get this message:

TransportError: U2F browser support is needed for Ledger. Please use Chrome, Opera or Firefox with a U2F extension. Also make sure you’re on an HTTPS connection. Make sure other apps (e.g. Ledger Live) or websites interacting with your HW wallet are closed. Also make sure to use the latest available version of the Cardano app/firmware on your HW wallet and web browser.

Where do u see this error… on adalite.io ?
Try to install google chrome browser

yes is did. I’ll try Alex, and I reached out to Ledger and Yoroi. Thanks so far!

1 Like

So Alex, it’s fixed. InYoroi, I added a new wallet and chose ‘connect to ledger Nano’. It made a new wallet, with the same number and contents in Yoroi! I renamed the old one (‘OLD’), cause I don’t know what happens if I delete it. The new one is running smoothly !

Weird stuff. But thanks again for your help, maybe this will solution will help others in the future


Delete the old one
You are welcome

I’m a bit afraid Alex. After I opened a new one, mysteriously with the same number and content, I’m afraid that deleting the old one might also delete the new one?

no man, trust me… delete the old one :wink: … anyway you have the ledger… so what can happen wrong?

You were right Alex! tnx again

1 Like

you are welcome :beers:

I have the same problem sending ada with my ledger x. Usb no problem , but bleutooth my ledger says ‘waiting for commands’.
I already asked emargo (yoroi) but the problem isnt solved.

Do i have to make a new wallet in yoroi? What happens with my old wallet. I have also cnfts in my wallet.
Can anyone help me with this problem step by step.

Thank you

Possible yoroi -ledger issues via bluetooth… connect the ledger via usb on laptop/PC (use adalite.io) and perform transactions from there

Oke thank you, but I want to use the ledger x with bleutooth not usb. Then should be better to buy the nano s. Thats cheaper.

Understand, you should open a ticket to yoroi


open yoroi → click settings → go to application → click on support → report a problem → submit the form



They will give you more detalis about this issue (please share with us)