Cannot stake/send ADA from iPhone with Ledger X

Hi, I hope someone can help me with my problem. I have installed Yoroi wallet on iPhone with Ledger X. It worked after I have installed the wallet and I have also received some ADA to the wallet. A couple of days later I wanted to stake my ADA. I exactly followed the instructions (Bluetooth enabled, Cardano App open on Ledger) but I always ends with a “Transaction Error” Message. I even cannot send the ADA to another address. Is this a known issue. I have my ADA sitting on my wallet an can do nothing with them.

1 Like

try to restore the ledger on from there try to delegate, perform a test transaction, etc perhaps are some issues with yoroi these days…

first u can try to restore the ledger on your iphone

Hi Alex, thanks for reaching out. What do you mean with “restore”? Would you delete the Yoroi on iPhone, download it again and then follow the restore routine in the wallet?

Yes, if ur ADA are on ledger (u should see on yoroi near wallet name) then delete the wallet from yoroi and restore it again - go to add wallet (shelley era) - connect ledger

There is “nothing” next to wallet name. What exactly should be there?



Mine looks like this - The name is an auto suggestion from Yoroi. Should be ok I guess

yes, now delete the wallet from yoroi and restore again

Deleted App, reconnected to ledger, see my ADA in the wallet, want to start staking and this error message comes up again

Ok, perhaps yoroi issues… connect the ledger on and stake from there

1 Like

Yep, had to use and have been able to initiate a transaction. Thxs for your help


I am having a very similar issue. not TRYING TO STAKE, but rather UNSTAKE/ SEND out of YOROI. let me break it down , first off. the issue is happening on both mobile and desktop. in regards to the desktop. i’m attempting to WITHDRAW MY STAKED REWARDS. every screen works fine all the way up until confirm. then takes me to a screen where it just says loading for about 5 seconds and then i get ‘Network error. please check your internet connection’ but my connection has never been faster.

also when i go to SEND my ADA from YOROI maybe it’s giving me a hard time because it’s staked and needs to be unstaked before i send it?? if that’s the case then i need help unstaking first. i’m connected with my ledger X and everything.

on my mobile YOROI. when i go to Withdraw my STAKING rewards/ AND OR SEND i get these errors. (see next post)
I had a second yoroi wallet that had no ledger connection or staking and could always send fine no problem. also my ledger works with every other asset no problem. now combining the two and they seem to always give me an error.
I saw that you have been recommended to go to

i’ve headed over to the website but I’m just going to enter my YOROI mnemonic phrase? like how do they connect to one another.
I SEEthat sooo many people have had their issues resolved using i want to know more please and guidance on how to use it in regards to connecting my yoroi.
i’ve been struggling with this for over a month and just found out about the forum. please someone help if possible. thank you so much

Wait more time till they will fix the issue (I know there is an issue only when u try to withdraw the rewards)

I just sent 10ADA for test and it worked!

Kinda “sad” that these guys cannot manage to provide a functioning wallet. I, after Alexd1985 helped me in pointing me to adalite, sold my ADA. To me, having to wait with my funds locked up is simply not acceptable. Cardano seems to be too academic, not able to solve the “day to day” issues.

1 Like

thank you so much!!! you’re literally awesome for helping me. hope you stay blessed !!

1 Like

there is just one issue with YOROI… you can’t withdraw the rewards… but you can perform transactions… I can live with this for few more days :wink:

Also not possible to even make a transaction. Had to do it with adalite. Anyway, no problem since it has been resolved. All good…

1 Like

Having similar issues I keep getting a decryption error message when trying to send.

Yoroi Byron wallet

go and restore your byron wallet on and send ADA from there to the yoroi shelley wallet,

first time send only 10 ADA, delete the shelley wallet from yoroi and restore the wallet (this way you will test if u bkped the seed words ok)
if everything is fine then send all ADA from byron to Shelley