Staking Transaction Failing in Yoroi Wallet - Ledger wallet in Yoroi

Hi All,

Good day to everyone, can you help me with my issue? I’m trying to delegate to a pool from my Yoroi Wallet, using my Ledger wallet that I connect with Yoroi, but it’s failing. What happens is when I click “Delegate” it opens a tab to confirm the transaction but it’s automatically closing as well.

I’m sure that my Ledger USB is on and I’m in the ADA App, all my versions are also up-to-date. So I was wondering why is my transaction not going through. Same thing when I also want to Send ADA to other wallet, it’s failing as well and the transaction confirmation is not going through in my Ledger. Please help. I appreciate your help on this. Thank you.


try to change the browser, if not working then try on connect via webUSB


thanks for your response, I tried other browsers but still the same.
Question for using, if I connect my ledger there, and stake my ledger wallet in, will I also see that in my Yoroi? coz I prefer using Yoroi wallet.

ofcourse, is an interface as yoroi or daedalus, if u will delegate from will be the same as you will delegate from yoroi; and yeah latter when u will connect on yoroi you will see the delegation made from

1 Like

alright thank you very much Alex. ok got it. I will try this method and will let you know if this works. :slight_smile: Thank you

It worked now Alex! Thanks for your help! I was able to stake in via webUSB using my Ledger Wallet. I checked my Ledger wallet in Yoroi and I can see that it’s already staked as well! Great job thank you so much!

1 Like