Cant stake through Ledger wallet on Yoroi

Hi all,
I just setup a Ledger Nano and transferred all my ada to it but it won’t let me delegate. As soon as I press the ‘Delegate’ button I get an error saying there was a problem. No error description is given. For ref, everything is up to date and I have BT on and Nano is unlocked with Cordano running. I tried multiple pools with the same outcome. any idea? TIA

EDIT: It did end up working using Yoroi app on Chrome


What operating system are u using, windows 10? There were few people with this issue and it’s possible to be related with some security settings from windows… same, they ended up to stake via adalite or yoroi chrome.


Hey Alex,
I was actually on macOS… which did the trick. Yoroi on iOS wasnt having it


I’m having the exact same issue, but when I tried to connect via a Chrome extension in lieu of the Firefox one, it simply keeps creating a new wallet. How did you accomplish?

Add wallet (Shelley) - connect Ledger (if u have a ledger wallet)