Trouble delegating and sending ada from Yoroi via Ledger Nano X

Hi, Wondering if someone can help. I can’t delegate or send my ADA with Ledger/Yoroi wallet. Ledger just says “waiting for commands” Eventually, I just cancel and I’ll get a message that says “something unexpected happened, please try again” I’m running OS Win10 64 if this helps. Cardano app is V2.3.2

1 Like

Try to change the browser, if still not working then u can delegate from adalite.io connect via webUSB

Thank you for responding. I’ve tried adalite.io and the same thing happened. I am using brave browser. I will try chrome. However, I am not sure how to set up on chrome with ledger. Do I use recover/restore wallet via hardware wallet feature?

Install chrome yoroi extension

  • open Yoroi
  • add wallet (shelley era)
  • connect ledger

Thank You, I’ll give that a shot this evening.

I can’t thank you enough for your help! Finally got it delegated using https://adalite.io via chrome browser. However, I couldn’t get my Nano X to connect with the default, WebHID or WebUSB options. I used the U2F and it connected. You just have to drag the pop up window that says “touch your security key” to the side and proceed.