Yoroi Chrome Extension with Ledger Nano - Cannot delegate

Trying to delegate from Ledger Nano via Yoroi chrome extension on Windows.

Tried in Brave browser, Iridium and now latest Google Chrome and all of them give the same error message.

I can log into the ledger, see my balances, transactions, etc. but when it comes to staking, the process involves many blinking screens. It appears it’s some sort of built-in Windows security issue. I took a screen grab.

The black Windows security box continually pops up and the delegation eventually fails.

Any ideas? Thanks.yoroierror


Perhaps some issues between yoroi- Ledger. Try to delegate from Adalite.io to check if there is ok.

I will appreciate if you will support me


I like to be supportive however I can. In what way can I support you?

1 Like


To tell ur friends to support small pools, this way they will help Cardano to be more decentralized


Still can’t delegate from Yoroi wallet using Chrome extension on Windows 10.

Is there an official Yoroi support channel because I’m not getting any help here.


Go to ledger live and see if u have the latest version of cardano app and ledger firmware…
If yes, then you can try to delegate from adalite.io

1 Like

Thanks. Yes, I do have all of the latest updates. It appears the error has something to do with Windows security although I accessed my Ledger wallet using Adalite just fine and delegated just fine.


Do you still have this problem with Yoroi Wallet and Ledger Nano? A solution may be to uninstall the Cardano App on Ledger. Make sure the Ledger firmware is updated on Ledger Live as once it is updated you will also be able to install the latest Cardano App. Good luck

Thank you. I believe the problem lies with Windows 10 security somehow. When verifying the login with the buttons of Ledger, the Windows security pop-up window continues to pop on and off the screen multiple times during the login process. Until it finally just gives an error message. If I manage to make it inside of the Yoroi wallet, it does the same bizarre thing when trying to delegate.

Adalite has been fine.


Did u tried on adalite.io - Connect with WebUSB option?