Can't update pool's registration metadata (pledge, relays)

Hello everyone,
I’m facing issues with the registration of my pool for a week now. Pool’s name is “[SAVE] Get High Reward & Save Biodiversity”. ([SAVE] Get High Rewards & Save Biodiversity | Cardano Staking)
When I first registered, the pool’s details appeared pretty fast on adapool but didn’t show up on pooltool. It appears actually that the pool’s info is not updated on pooltool but it exists with pool ID only (name is empty):
Cardano PoolTool - The most comprehensive staking statistics for Cardano on the web.
Since then, I find no way to update pool’s information, whatever plateform I’m looking at.
I’ve set my pledge from 9.5k to 10.8k, I added a new relay, but no luck, nothing moves when I do a transaction. I also have proof that those transactions are valid because I can see them in the History tab of adapool (4 transaction at the moment, which makes 3 useless ones).

I’m assuming I understand the registration (and whole setup) processes and I have not any more clue about what’s wrong. I tried using Relay IP, and DNS names. I tried a different name for the metadata file, among other things. Awesome tool reports that online hash of metadata file is not the same than registered hash on the blockchain, but I’m actually really trying to update this one ! (I confirm that the hash is correct, you can check by yourself if any doubt).

Command I’m using is :

   cardano-cli stake-pool registration-certificate --cold-verification-key-file /root/cold.vkey --vrf-verification-key-file $keys/vrf.vkey \
	--pool-pledge 11800000000 --pool-cost 340000000 --pool-margin 0 \
	--pool-reward-account-verification-key-file $addrkeys/stake.vkey --pool-owner-stake-verification-key-file $addrkeys/stake.vkey --mainnet \
    --single-host-pool-relay --pool-relay-port 3001 \
    --single-host-pool-relay --pool-relay-port 3001 \
	--metadata-url --metadata-hash 63f5bcfb03d6ab01ca92a092b7ed7c326de04b5cb37c8e2934e0a3f635756c63 \
	--out-file pool-registration.cert

Do I have to regenerate a file beside pool-registration.cert when I want to reregister ? Can you please help ? :slight_smile:

1 Like


First let’s see is there any issue with your pool registration so far…
use this site:

Metadata hash 63f5bcfb03d6ab01ca92a092b7ed7c326de04b5cb37c8e2934e0a3f635756c63 doesn't match registered hash 2943b475e0d28947c5b1d6ef49fe652165b8703ccd89be9e1dd1ee922209f9b4

you have metadata hash issues, I recommend to go through on this site where you can get instructions what to do:

You need to rehash your metadata each time you change it. Which instructions have been you following? cntools, coincashew…?

Hello laplasz and jeremyisme,
In my post, I cover this subject exactly :slight_smile: I used myself and saw that issue. Of course I rehashed my metadata file (I’m Linux system administrator +10 years, I’m well accustomed to cryptographic tools and usages), and I’m pretty sure it’s valid now :

cardano-cli stake-pool metadata-hash --pool-metadata-file <(curl

That hash (63f5bcfb0…) is the one I’m using now to register, at least when I create my pool-registration certificate.
@jeremyisme : I’ve been using several docs at the same time to get a better understanding of the process : Official one, the coincashew …

And indeed, if I request the smash server, it tells about my old metadata hash, not my current one. Why isn’t it updated on smash’s side although my transactions are fine ?

curl -s ""| jq .
    "time": "14.04.2021. 09:09:01",
    "retryCount": 6,
    "poolHash": "2943b475e0d28947c5b1d6ef49fe652165b8703ccd89be9e1dd1ee922209f9b4",
    "cause": "Hash mismatch from poolId 'f799b4b4418b3b668697d6c71bafecf23f85196f264286f462c3e959' when fetching metadata from ''. Expected 2943b475e0d28947c5b1d6ef49fe652165b8703ccd89be9e1dd1ee922209f9b4 but got 63f5bcfb03d6ab01ca92a092b7ed7c326de04b5cb37c8e2934e0a3f635756c63.",
    "poolId": "f799b4b4418b3b668697d6c71bafecf23f85196f264286f462c3e959",
    "utcTime": "1618391341.168969s"

Interesting thing here, I can see that smash is still using my last poolMetadata.json file name although it has changed. I indeed moved to a lowercase file because I saw this advice here on the forum, about changing metadata file name so it can be reloaded by smash… but no luck.

1 Like

That means that your transactions not fine…something went wrong during re-registration…
how did you verify your transactions?

Ok I guess I found my issue :expressionless:
There was a typo in my transaction build command and I was registering the same old certificate over and over again, altough a new one was generated beside and was not used by my command, and I didn’t realize that.


Let’s see if it solves all my troubles.
Thank you for your answers so far, appreciate it :slight_smile:

1 Like

name of the movie?:slight_smile:

(Sorry for the big pictures, didn’t realize it was so big and wouldn’t be resized ahah)
It’s from an epic Game of Thrones episode !

Yeah, I know what you mean. I spent a long time trying to solve a similar issue before I figured out 6 and 9 are not the same number!!

1 Like