Cardano Wallet you are trying to restore already exists

Normally I wouldn’t bother joining a forum unless I have a problem.

So … I have a problem.

This morning I got the dreaded YELLOW PAGE when attempting to log in to my DAEDALUS INCENTIVISED TESTNET REWARDS WALLET as I usually do.

YELLOW SCREEN - so followed instructions.
I deleted the old setup link and installed the NEW link.
New software is REWARDS (2.1.0-ITN1#

So far so good … until I made the log in connection successfully.

From this point on I am under restraint because we are civilised here.
I was asked to either Create or Restore a Wallet.
Naturally I chose “RESTORE.”
Proceeded through the steps - you know the drill - Recovery Phrase, Password etc, only to read:

We I know that, and now all of the Cardano Forum KNOWS THAT.
I searched for a solution to this, but the older solutions do not work.
So where do we go from here?
Why does a fix have to destroy all of the previous work?
Why wasn’t there more notice/education about this?

I am a member of YouTube channels, and guess I will need to wait until someone on there proposes the solution. I am still waiting for an answer from a Support Ticket I placed about 2 weeks ago.
So now it looks like 500,000 people will be trying to update and sync their new Testnet Reward Wallets.
Is this really necessary??
Oh well - I guess it will be ok one day.


have you tried this ?

so, this is not working for you?

also guys, please install a network monitor on your system. or use an existing one like the “networkmonitor” in kaspersky antivirus so you will see, that jormungandr is making connections out to the world. and don’t forget, daedalus is a FULL NODE, not a light node like the yoroi wallet. so, you have to be patient on the startup because you have to download the ~300MB data from the bootstrap peers first in the background.


The issue happened AFTER D/L the latest version released yesterday.14th February 2020.

I have since solved the issue by:

  • Deleting specific files in the state directory.
  • Reinstalling the new version.
  • Using my Recovery Phrase and PW to Restore the wallet.

The connection was eventually made and I was able to open the Rewards Testnet and log in/Restore Wallet.
After about 25 minutes of allowing it to run and sync or whatever, it suddenly switched to the Data side, showing a previous pool I had delegated to. I just let it run and update, and next it displayed my delegated ADA figures and Rewards. Finally the incorrect Pool was replaced by the correct/current pool.

I also noticed during this, that the Pool I am delegated into to switched ranking positions about 6 times.

But happy now that this is done and updated.

I am certain I am not the only person in the world of ADA to have found this issue.
I must have missed the education that IOHK/Cardano must have or should have put out to assist people to be prepared.

Won’t be too hard on them b/c they work incredibly hard at getting this to a foolproof state.
But it is better to build a fence at the top of the cliff, rather than park an ambulance at the bottom!
After all, they weren’t to know that someone like me wouldn’t be able to work out that it was the state directory (whatever that is) all along.

Thanks for your responses, ATADA and Heyto. really appreciated.
I am happy to declare - “PROBLEM SOLVED.”


Problem solved - please refer to my response to the other suggestion.

Thank you for your kind assistance

1 Like

Why do I have to restore my wallet when the wallet already exists in the first place? I wanted my wallet to stay intact because I don’t know what happens with the stake I’ve delegated to the pool and the rewards that come with it. And now I had to delete the content of the state directory.

Don’t know, either some technical reason or it’s a bug, but there’s no point being concerned about that, the way around it is to do the delete, restart and wait for sync, THEN restore the Rewards wallet.

That doesn’t work even I would delete all files of state directory.

THIS works.

What works?

Can someone in this thread please provide step by step instructions for how to resolve this issue rather then saying something generic like: “Deleting specific files in the state directory.”

What files…

Use Yoroi! Download the chrome extension and use your 15 seed words to restore your wallet. I was using Daedalus too but switched to Yoroi and it works perfectly.

im having this same issue. i tried deleting everything and rebooting still no luck

Well? What is the solution?

Use Yoroi or wait for update.

I’m about to try the above myself but here is a thread from Reddit with a alternative method:

So I tried the method mentioned in the beginning of the thread which is to delete the contents of the state directory by following the instructions here:

There was some questions to what a state directory is as the term is unfamiliar to some. It appears to be the file directory which contains the information about your wallet. Once you delete it you start from scratch so you need your secret words.

To get to the state directory from inside Daedalus follow the instructions here:

You can also find this directory from the file explorer and do the same thing but doing it from inside Daedalus makes it easy to find.