Reward Wallet stuck "Connecting to network"

Ah… glad you found it!

Daedalus has been a disaster in this ITN testing. Nothing in this blog addresses the issues permanently. There is supposed to be another release any day now - but it never comes. Very disappointing… When the next release of this wallet comes and this issues is not completely resolved the ADA community will have lost a big supporter.

Can’t be that great a supporter who’s willing to jump ship over a testnet wallet not working properly, and there are alternatives (Yoroi).

3 Likes

How is switching to Yoroi going to fix Daedalus? Why are their two wallets?

yoroi was developed by emurgo and its a light wallet for Cardano. There is no need to download the blockchain when you open the wallet .

Daedalus has some problems at the moment which will be fixed in the future, until then you can use yoroi without any problems.

2 Likes

Can I have your ADA then? :wink:

The incentivized testnet is in fact quite successful – participation is through the roof, useful data is flooding in, and yes, the downside is that the network is hopelessly congested at this point.

Daedalus Rewards is pretty much dead in the water because that’s a full node wallet, and it currently syncs at roughly the speed of a particularly sluggish tectonic plate… Yoroi doesn’t store its own full copy of the blockchain, so it is far less affected by this.

2 Likes

ITN1 Daedalus Wallet 2.1.0 is out right now!
https://staking.cardano.org/en/delegation/

Yeah. Unfortunately I have the same connection issues…Deleted everything…did A fresh install. I saw the screen to format the date etc. I agreed to the terms of service…Then it tries to connect forever again. I was never given the option to restore the wallet or create a new one too…Guess I’ll have to wait for another realease

The reason you haven’t seen create/restore is that you deleted everything, in that situation it syncs first – unless of course it fails to connect. I’m in exactly the same situation, but I only tried Daedalus 2.1 out of curiosity, Yoroi is immensely better ATM.

how long have you waited for the sync?

do you have a networkmonitor software installed, here you can see that the wallet is making connections and doing downloads.

It is stuck “connecting to network”…Luckily I am satisfied with my current stakepool so it isn’t really necessary to open Daedalus (or switching to Yoroi). But I must admit I can’t wait for the Haskell testnet launch and hope these issues are ironed out

I simply installed over the old version, but I get the create/restore screen anyway. When I try to restore my rewards wallet it says that wallet already exists. Go figure.

Back to Yoroi…

(Connecting and syncing works now, I’ll give it that.)

EDIT: just found this – seems I’m not the only one having this problem. I’ll fiddle around with it some more when I have the time…

are are already a few threads here with a solution.

have you checked it with a network monitor while it is
“connecting to the network” ??? if not, do it.

1 Like

Thanks Rob. I already have my kids wallets on Yoroi, So I don’t want to mess around…

Does that solve the syncing problem? Now that I updated to the 2.1.0-ITN Deadelus rewards It won’t connect at all anymore so it’s even worse then the previous version.

Hi Chris, thanks. Should I copy that content in a notepad file and rename it to jormungandr-config.yaml ?

Hi Armando. The jormungandr-config.yaml for 2.1 uses some different peers, so don’t use mine for the time being. I’ll let you know when I’ve updated the file.

Ah OK thanks Chris

For me it took quite a while but did it eventually.