Restoring the wallet already exists


when I try to restore my wallet on ITN 2.1.0 it says that the restoring wallet already exists. What should I do?

Please read in the Forum, that question was answered now multiple times. Thank you!

1 Like

I haven’t found answer or the solution in the forum for my problem yet. I tried to delete all files of state directory and I even install Daedalus ITN 2.1.0 again but that wasn’t a solution for anything. I have still a same error: wallet already exists. If someone have a some tips to solve this problem it would be nice to hear.

Plenty of people have found their answer here, including me, so don’t say there’s none.

If you correctly deleted all of the files in the state dir you would not get that message, I suggest you try that again.

1 Like

I have done that multiple times so unfortunately that doesn’t work. I have done that many times before 2.1.0 and then it worked very well. If for someone that is the solution then they have been found the answer but I did not. Some reason that not work with my Mac Os in this time.

For many reasons, all wallet info is stored in state directory and its subdirectories, nowhere else, to the best of my knowledge. If Daedalus thinks a wallet already exists, the state directory cannot be empty. I don’t know much about Macs so cannot give more specific info, sorry.

1 Like

I deleted the whole directory so state directory is gone and when I start daedalus again obviously it create whole new one. That is why I’m wondering how that can be possible but it is what is. Like I wrote earlier I have done state directory deleting many times before 2.1.0 and then there was not any problems so I’m quite sure that I’m know how to do the state directory deleting.

I have a hunch that would be some hidden folder or staff like that, but anyways I’m keep looking. Thanks anyway your support - I appreciate that.

1 Like

I have the same problem but only with the balance wallet. When I restore a rewards wallet that works although it takes a very long time to sync.

Same problem here.
I also removed the “Cardano ITN” folder under %appdata%.

You only need the Rewards wallet. Syncing does take a while.

1 Like

Yes the “already exist” -problem appear first with balance wallet restoring. I tried to restore my rewards wallet as well but there’s a notice “The balance and transaction history of this wallet is 0 % synced with the blockchain”. Daedalus ITN 2.1.0 has been synced now over 4 hours, but it won’t go forward. If I close Daedalus it jump all begining and it needs to start restoring again. Then if I try to restore rewards wallet the problem “already exist” appear rewards wallet as well. In that case I needs to delete state directory again.

That’s why I have been waiting now about 4 hours and I haven’t close Daedalus yet even syncing wouldn’t seems to go forward. It would be nice to hear if someone has an experience how long that syncing should takes or is it normal that this takes this long.

I really appreciate all your support and it’s nice to notice that here are people who really cares.

I think I found the solution for this problem. Probably the reason was trying to restore balance wallet first before the rewards ones.

For me solution was:

  1. Delete state directory
  2. Skip balance wallet restoring
  3. Restore only rewards wallet(s)

Actually I have also newest jcli and jormungandr files and tuned jrmgnr.config.yaml

Thanks for all your support and I hope this helps someone other as well.

Cheers adajaws!

1 Like

Of course you meant reward wallets.

Yes indeed, thanks mate. I fixed the post.

1 Like